Bug 130127 - Removing Akregator component in kontact leaves stale tray icon
Summary: Removing Akregator component in kontact leaves stale tray icon
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: kontact plugin (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-01 22:35 UTC by Stefan Borggraefe
Modified: 2006-07-07 21:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Borggraefe 2006-07-01 22:35:29 UTC
Version:           1.2.3 (using KDE KDE 3.5.3)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Steps to reproduce:
1. Start Kontact and also start the embedded Akregator by clicking on the "Feeds" icon.
2. Select "Settings|Configure Kontact...|Select Components..." and remove the "Feeds" component.
3. Note that the Akregator systray icon is still there.
4. Select "Settings|Configure Kontact...|Select Components..." and add the "Feeds" component again.
5. Click on the "Feeds" icon.
6. Note that another Akregator systray icon is added.
7. Repeat steps 2 to 6 to get arbitrary many Akregator instances. ;-)

I guess this could be fixed by ensuring Akregator is properly ended when removed as a Kontact component.
Comment 1 Frank Osterfeld 2006-07-07 20:56:47 UTC
Confirmed - looks like it only affects the tray icon though, there aren't multiple parts instantiated (tray icon context menu entries have no effect, no akregator in dcop...)
Comment 2 Frank Osterfeld 2006-07-07 21:08:10 UTC
SVN commit 559615 by osterfeld:

remove tray icon when disabling akregator component in kontact
BUG: 130127


 M  +1 -0      ChangeLog  
 M  +2 -0      src/akregator_part.cpp  
 M  +0 -2      src/librss/tools_p.cpp  


--- branches/KDE/3.5/kdepim/akregator/ChangeLog #559614:559615
@@ -7,6 +7,7 @@
 
 Bug fixes:
 
+ 2006/07/07 Remove tray icon when disabling Akregator part in Kontact (#130127) -fo
  2006/07/07 Fix a crash on shutdown occurring in ProgressManager (#130377) -fo
  2006/06/25 Fix context menus in browser tab, show appriopriate entries when
             text is selected (copy action) or the cursor is over a link 
--- branches/KDE/3.5/kdepim/akregator/src/akregator_part.cpp #559614:559615
@@ -263,6 +263,8 @@
     saveTagSet(m_tagSetPath);
     m_view->slotOnShutdown();
     //delete m_view;
+    delete TrayIcon::getInstance();
+    TrayIcon::setInstance(0L);
     delete m_storage;
     m_storage = 0;
     //delete m_actionManager;
--- branches/KDE/3.5/kdepim/akregator/src/librss/tools_p.cpp #559614:559615
@@ -230,8 +230,6 @@
     
     if (name.isNull())
         name = email;
-            
-    QString author;
     
     if (!email.isNull())
         return QString("<a href=\"mailto:%1\">%2</a>").arg(email).arg(name);