Bug 130067 - Crashed when changing font size
Summary: Crashed when changing font size
Status: RESOLVED DUPLICATE of bug 84739
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-30 13:40 UTC by greatbunzinni
Modified: 2006-07-07 12:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash backtrace (5.82 KB, text/plain)
2006-06-30 13:41 UTC, greatbunzinni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description greatbunzinni 2006-06-30 13:40:55 UTC
Version:           1.5.3 (using KDE KDE 3.5.3)

Umbrello crashed on me when I tried to change Umbrello's font size. When I re-ran Umbrello, the font size was unchanged.
Comment 1 greatbunzinni 2006-06-30 13:41:19 UTC
Created attachment 16834 [details]
Crash backtrace
Comment 2 Oliver Kellogg 2006-06-30 18:04:27 UTC
The new code generators are broken.
This is known, so please do not report bugs with them active.
I.e. go to the Configure Umbrello -> General Settings and disable
the checkbox "use new C++/Java/Ruby code generators".
Comment 3 Oliver Kellogg 2006-07-05 07:09:13 UTC
Does the problem also happen when using the old code generators?
If I don't hear back then I will close this PR.
Comment 4 greatbunzinni 2006-07-05 15:58:48 UTC
How do I do that? When it crashed on me I wasn't aware that I was messing with a code generator.
Comment 5 Oliver Kellogg 2006-07-05 19:03:31 UTC
Well, your crash backtrace shows CPPCodeGenerator::syncCodeToDocument(),
and that's a new-codegen bummer.
Comment 6 greatbunzinni 2006-07-07 10:25:32 UTC
Strange. When the crashe happened I just opened an Umbrello project, went to Umbrello's options dialog and changed the font size. I never fiddled with anything related to the project itself, let alone a code generator (at least knowingly).
Comment 7 Oliver Kellogg 2006-07-07 12:28:28 UTC

*** This bug has been marked as a duplicate of 84739 ***