Bug 130063 - Focus follows mouse does not change focus after drag&drop
Summary: Focus follows mouse does not change focus after drag&drop
Status: RESOLVED DUPLICATE of bug 142040
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-30 11:34 UTC by munlinux
Modified: 2007-03-23 15:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description munlinux 2006-06-30 11:34:34 UTC
Version:            (using KDE KDE 3.4.3)
Installed from:    Ubuntu Packages

Is this an AmaroK bug or KDE Windowing system bug? 

I reported this earlier as AmaroK bug 127836, which was marked "INVALID", as they judged this to be "a window manager issue, afaict".

With window focus setting set to "Focus Follows Mouse", AmaroK window does not gain focus when files are dragged and dropped to it.

When you further move mouse on AmaroK, it still doesn't get focus. Only when you move your mouse away from the AmaroK window and then back does the player gain focus. 

PS. The annoying thing - you drag and drop from somewhere in your file system (or from desktop), and then press Del to remove e.g. the currently playing song in AmaroK, only to find out that the "Del" keypress was relayed to the desktop, and those files are then deleted / "moved to trash", with / without confirmation asked, according to what settings you have.
Comment 1 munlinux 2007-02-21 22:28:12 UTC
This issue is somewhat parallel to the one described in bug 142040, showing similar symptoms.
Comment 2 Lubos Lunak 2007-03-23 15:54:44 UTC

*** This bug has been marked as a duplicate of 142040 ***