Bug 129810 - kwrite crashes when the file loaded is changed on disk.
Summary: kwrite crashes when the file loaded is changed on disk.
Status: RESOLVED DUPLICATE of bug 123315
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-25 22:34 UTC by illogic-al
Modified: 2006-06-26 09:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description illogic-al 2006-06-25 22:34:39 UTC
Version:           4.5.2 (using KDE 3.5.2, Arch Linux)
Compiler:          Target: i686-pc-linux-gnu
OS:                Linux (i686) release 2.6.16-ARCH

This problems described below appear on the version of KWrite accompanying KDE 3.5.2. 
Steps to reproduce
1. Open a file in kwrite (The one I've been using is ~/.kde/share/config/kdesktoprc) and edit it.
2. Save the change
3. Cause a change to happen outside of the program. The way I do this is by going to KControl -> KDE Components -> File Manager and changing the [] Display file sizes in bytes checkbox and then pressing the Apply button.
4. Go back to the KWrite window. In my example kdestoprc will have been changed outside the program and the  "File Changed on Disk" dialog will appear. 
5. Choose the "Reload File" option
6. Go back to the KDE Control Module and change a different setting. What I did was to go to the Previews and Meta-Data tab and increase the "Maximum file size: " slider. After making a change press the apply button.
7. See Kwrite go boom.

You should only need to repeat steps 4-6 twice more, at most to observe this crash. 
a) Please test exactly as listed before saying this bug is no longer present (in 3.5.3 or svn). b) Feel free to add a better backtrace.
Comment 1 illogic-al 2006-06-25 22:35:29 UTC
bt

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1239664928 (LWP 16203)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#9  0xb745ac99 in operator== () from /opt/qt/lib/libqt-mt.so.3
#10 0xb7d41221 in KDirWatchPrivate::slotActivated ()
   from /opt/kde/lib/libkio.so.4
#11 0xb7d42d68 in KDirWatchPrivate::qt_invoke () from /opt/kde/lib/libkio.so.4
#12 0xb7189ad9 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#13 0xb718a0a1 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#14 0xb74c5890 in QSocketNotifier::activated () from /opt/qt/lib/libqt-mt.so.3
#15 0xb71a8950 in QSocketNotifier::event () from /opt/qt/lib/libqt-mt.so.3
#16 0xb712a6a1 in QApplication::internalNotify ()
   from /opt/qt/lib/libqt-mt.so.3
#17 0xb712b09f in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#18 0xb782b03e in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#19 0xb711e6ed in QEventLoop::activateSocketNotifiers ()
   from /opt/qt/lib/libqt-mt.so.3
#20 0xb70d83f5 in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#21 0xb71411d3 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#22 0xb71410b6 in QEventLoop::exec () from /opt/qt/lib/libqt-mt.so.3
#23 0xb712a0bf in QApplication::exec () from /opt/qt/lib/libqt-mt.so.3
#24 0xb7698268 in kdemain () from /opt/kde/lib/libkdeinit_kwrite.so
#25 0xb5f92734 in kdeinitmain () from /opt/kde/lib/kde3/kwrite.so
#26 0x0804dc46 in ?? ()
#27 0x00000002 in ?? ()
#28 0x08109b30 in ?? ()
#29 0x00000001 in ?? ()
#30 0x00000000 in ?? ()
Comment 2 Hamish Rodda 2006-06-26 09:41:35 UTC

*** This bug has been marked as a duplicate of 123315 ***