Bug 129540 - Crashes on using www.findvej.dk
Summary: Crashes on using www.findvej.dk
Status: RESOLVED DUPLICATE of bug 128015
Alias: None
Product: konqueror
Classification: Applications
Component: kjs (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-21 06:08 UTC by Sune Vuorela
Modified: 2006-06-21 10:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sune Vuorela 2006-06-21 06:08:37 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Hi!

konqueror (more particulary kjs, I guess) crashes when I am using a danish map service, findvej.dk.

How to reproduce:
go to findvej.dk > in the field "Adresse" write an existing road in denmark, like "Solbjerg plads" (without the "")  > Press "søg" (search) and crash.

Here is the backtrace:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1500927776 (LWP 26917)]
[KCrash handler]
#5  0xa5e7b37f in DOM::NodeListImpl::Cache::updateNodeListInfo (
    this=0x8321850, doc=0x0)
    at /build/buildd/kdelibs-3.5.3/./khtml/xml/dom_nodeimpl.cpp:1774
#6  0xa5e7fa05 in DOM::NodeListImpl::length (this=0x87d7320)
    at /build/buildd/kdelibs-3.5.3/./khtml/xml/dom_nodeimpl.cpp:1652
#7  0xa60214e9 in DOM::NodeList::length (this=0x0)
    at /build/buildd/kdelibs-3.5.3/./khtml/dom/dom_node.cpp:476
#8  0xa5faeff1 in KJS::DOMNodeList::tryGet (this=0x875fab8, exec=0xafc6a8b4, 
    p=@0xafc6a4f8) at /build/buildd/kdelibs-3.5.3/./khtml/ecma/kjs_dom.cpp:611
#9  0xa5fc2426 in KJS::DOMObject::get (this=0x0, exec=0xafc6a8b4, 
    p=@0x8321850)
    at /build/buildd/kdelibs-3.5.3/./khtml/ecma/kjs_binding.cpp:50
#10 0xa5d217c2 in KJS::Reference::getValue (this=0xafc6a4e8, exec=0xafc6a8b4)
    at /build/buildd/kdelibs-3.5.3/./kjs/reference.cpp:143
#11 0xa5d21d12 in KJS::Node::evaluate (this=0x0, exec=0xafc6a8b4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:130
#12 0xa5d334ad in KJS::RelationalNode::evaluate (this=0x869f0f0, 
    exec=0xafc6a8b4) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1339
#13 0xa5d01d93 in KJS::Node::toBoolean (this=0x0, exec=0xafc6a8b4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:136
#14 0xa5d36f73 in KJS::ForNode::execute (this=0x83dacb0, exec=0xafc6a8b4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:2190
#15 0xa5d3a9cd in KJS::SourceElementsNode::execute (this=0x83dab98, 
    exec=0xafc6a8b4) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3097
#16 0xa5d35d2c in KJS::BlockNode::execute (this=0x83db5c8, exec=0xafc6a8b4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#17 0xa5d3b9e9 in KJS::DeclaredFunctionImp::execute (this=0x0, exec=0x0)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:588
#18 0xa5d220cd in KJS::FunctionImp::call (this=0x8786b70, exec=0xafc6ae54, 
    thisObj=@0x8321850, args=@0xafc6a984)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:363
#19 0xa5d2583c in KJS::Object::call (this=0x0, exec=0xafc6ae54, thisObj=@0x0, 
    args=@0x0) at /build/buildd/kdelibs-3.5.3/./kjs/object.cpp:73
#20 0xa5d33ba2 in KJS::FunctionCallNode::evaluate (this=0x83b5640, 
    exec=0xafc6ae54) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:870
#21 0xa5cf4493 in KJS::AssignExprNode::evaluate (this=0x0, exec=0x0)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1760
#22 0xa5d22681 in KJS::VarDeclNode::evaluate (this=0x8681540, exec=0xafc6ae54)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1791
#23 0xa5d22546 in KJS::VarDeclListNode::evaluate (this=0x83b5670, 
    exec=0xafc6ae54) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1863
#24 0xa5d35b33 in KJS::VarStatementNode::execute (this=0x83b5688, 
    exec=0xafc6ae54) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1896
#25 0xa5d3a937 in KJS::SourceElementsNode::execute (this=0x83b56b8, 
    exec=0xafc6ae54) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3091
#26 0xa5d35d2c in KJS::BlockNode::execute (this=0x83b59a0, exec=0xafc6ae54)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#27 0xa5d361c1 in KJS::IfNode::execute (this=0x83b59d0, exec=0xafc6ae54)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:2021
#28 0xa5d3a9cd in KJS::SourceElementsNode::execute (this=0x83b3880, 
    exec=0xafc6ae54) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3097
#29 0xa5d35d2c in KJS::BlockNode::execute (this=0x83b6ed8, exec=0xafc6ae54)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#30 0xa5d3b9e9 in KJS::DeclaredFunctionImp::execute (this=0x0, exec=0x0)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:588
#31 0xa5d220cd in KJS::FunctionImp::call (this=0x8786bb8, exec=0xafc6b314, 
    thisObj=@0x8321850, args=@0xafc6af24)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:363
#32 0xa5d2583c in KJS::Object::call (this=0x0, exec=0xafc6b314, thisObj=@0x0, 
    args=@0x0) at /build/buildd/kdelibs-3.5.3/./kjs/object.cpp:73
#33 0xa5d33ba2 in KJS::FunctionCallNode::evaluate (this=0x8339fb8, 
    exec=0xafc6b314) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:870
#34 0xa5d35ecf in KJS::ExprStatementNode::execute (this=0x87870f8, 
    exec=0xafc6b314) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1980
#35 0xa5d3a937 in KJS::SourceElementsNode::execute (this=0x8787128, 
    exec=0xafc6b314) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3091
#36 0xa5d35d2c in KJS::BlockNode::execute (this=0x8787160, exec=0xafc6b314)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#37 0xa5d361c1 in KJS::IfNode::execute (this=0x8787190, exec=0xafc6b314)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:2021
#38 0xa5d3a9cd in KJS::SourceElementsNode::execute (this=0x83b80d8, 
    exec=0xafc6b314) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3097
#39 0xa5d35d2c in KJS::BlockNode::execute (this=0x8787268, exec=0xafc6b314)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#40 0xa5d3b9e9 in KJS::DeclaredFunctionImp::execute (this=0x0, exec=0x0)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:588
#41 0xa5d220cd in KJS::FunctionImp::call (this=0x87b58f0, exec=0xafc6b7d4, 
    thisObj=@0x8321850, args=@0xafc6b3e4)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:363
#42 0xa5d2583c in KJS::Object::call (this=0x0, exec=0xafc6b7d4, thisObj=@0x0, 
    args=@0x0) at /build/buildd/kdelibs-3.5.3/./kjs/object.cpp:73
#43 0xa5d33ba2 in KJS::FunctionCallNode::evaluate (this=0x86f75b8, 
    exec=0xafc6b7d4) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:870
#44 0xa5d35ecf in KJS::ExprStatementNode::execute (this=0x86f75d0, 
    exec=0xafc6b7d4) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1980
#45 0xa5d3a937 in KJS::SourceElementsNode::execute (this=0x86f7600, 
    exec=0xafc6b7d4) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3091
#46 0xa5d35d2c in KJS::BlockNode::execute (this=0x86f7738, exec=0xafc6b7d4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#47 0xa5d361c1 in KJS::IfNode::execute (this=0x86f7768, exec=0xafc6b7d4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:2021
#48 0xa5d3a937 in KJS::SourceElementsNode::execute (this=0x86f77a0, 
    exec=0xafc6b7d4) at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:3091
#49 0xa5d35d2c in KJS::BlockNode::execute (this=0x86f77d8, exec=0xafc6b7d4)
    at /build/buildd/kdelibs-3.5.3/./kjs/nodes.cpp:1942
#50 0xa5d3b9e9 in KJS::DeclaredFunctionImp::execute (this=0x0, exec=0x0)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:588
#51 0xa5d220cd in KJS::FunctionImp::call (this=0x8439c98, exec=0x8557fc0, 
    thisObj=@0x8321850, args=@0xafc6b8b0)
    at /build/buildd/kdelibs-3.5.3/./kjs/function.cpp:363
#52 0xa5d2583c in KJS::Object::call (this=0x0, exec=0x8557fc0, thisObj=@0x0, 
    args=@0x0) at /build/buildd/kdelibs-3.5.3/./kjs/object.cpp:73
#53 0xa5fc3f5e in KJS::JSEventListener::handleEvent (this=0x89072a0, 
    evt=@0xafc6b924)
    at /build/buildd/kdelibs-3.5.3/./khtml/ecma/kjs_events.cpp:95
#54 0xa5f98bd7 in KJS::XMLHttpRequest::changeState (this=0x882b990, 
    newState=KJS::Completed)
    at /build/buildd/kdelibs-3.5.3/./khtml/ecma/xmlhttprequest.cpp:254
#55 0xa5ffb82c in KJS::XMLHttpRequest::slotFinished (this=0x882b990)
    at /build/buildd/kdelibs-3.5.3/./khtml/ecma/xmlhttprequest.cpp:587
#56 0xa5ffb8c7 in KJS::XMLHttpRequestQObject::slotFinished (this=0x0, job=0x0)
    at /build/buildd/kdelibs-3.5.3/./khtml/ecma/xmlhttprequest.cpp:93
#57 0xa5ffcf0a in KJS::XMLHttpRequestQObject::qt_invoke (this=0x8903260, 
    _id=3, _o=0xafc6ba54) at ./xmlhttprequest.moc:98
#58 0xa724554b in QObject::activate_signal (this=0x88f4ad8, clist=0x8799ec0, 
    o=0xafc6ba54) at kernel/qobject.cpp:2356
#59 0xa7a837e2 in KIO::Job::result (this=0x88f4ad8, t0=0x0)
    at ./jobclasses.moc:162
#60 0xa7ad783c in KIO::Job::emitResult (this=0x88f4ad8)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/job.cpp:226
#61 0xa7ad79ae in KIO::SimpleJob::slotFinished (this=0x88f4ad8)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/job.cpp:574
#62 0xa7ad80ed in KIO::TransferJob::slotFinished (this=0x88f4ad8)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/job.cpp:944
#63 0xa7ad971a in KIO::TransferJob::qt_invoke (this=0x88f4ad8, _id=17, 
    _o=0xafc6bddc) at ./jobclasses.moc:1071
#64 0xa724554b in QObject::activate_signal (this=0x8139fa0, clist=0x8520920, 
    o=0xafc6bddc) at kernel/qobject.cpp:2356
#65 0xa7245fdc in QObject::activate_signal (this=0x8139fa0, signal=6)
    at kernel/qobject.cpp:2325
#66 0xa7a7e44c in KIO::SlaveInterface::finished (this=0x0)
    at ./slaveinterface.moc:226
#67 0xa7aef4f8 in KIO::SlaveInterface::dispatch (this=0x8139fa0, _cmd=104, 
    rawdata=@0xafc6bfe0)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/slaveinterface.cpp:243
#68 0xa7a96c87 in KIO::SlaveInterface::dispatch (this=0x8139fa0)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/slaveinterface.cpp:173
#69 0xa7a9bb9b in KIO::Slave::gotInput (this=0x8139fa0)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/slave.cpp:300
#70 0xa7a9bd4b in KIO::Slave::qt_invoke (this=0x8139fa0, _id=4, _o=0xafc6c108)
    at ./slave.moc:113
#71 0xa724554b in QObject::activate_signal (this=0x8583358, clist=0x8341a18, 
    o=0xafc6c108) at kernel/qobject.cpp:2356
#72 0xa7245e52 in QObject::activate_signal (this=0x8583358, signal=2, 
    param=19) at kernel/qobject.cpp:2449
#73 0xa75d7f7f in QSocketNotifier::activated (this=0x8583358, t0=19)
    at .moc/debug-shared-mt/moc_qsocketnotifier.cpp:85
#74 0xa726580a in QSocketNotifier::event (this=0x8583358, e=0xafc6c460)
    at kernel/qsocketnotifier.cpp:258
#75 0xa71db87a in QApplication::internalNotify (this=0xafc6c79c, 
    receiver=0x8583358, e=0xafc6c460) at kernel/qapplication.cpp:2635
#76 0xa71dba76 in QApplication::notify (this=0xafc6c79c, receiver=0x8583358, 
    e=0xafc6c460) at kernel/qapplication.cpp:2358
#77 0xa78b224e in KApplication::notify (this=0xafc6c79c, receiver=0x8583358, 
    event=0xafc6c460)
    at /build/buildd/kdelibs-3.5.3/./kdecore/kapplication.cpp:550
#78 0xa716d001 in QApplication::sendEvent (receiver=0x8583358, 
    event=0xafc6c460) at kernel/qapplication.h:520
#79 0xa71cd435 in QEventLoop::activateSocketNotifiers (this=0x80e5808)
    at kernel/qeventloop_unix.cpp:578
#80 0xa7180d06 in QEventLoop::processEvents (this=0x80e5808, flags=4)
    at kernel/qeventloop_x11.cpp:383
#81 0xa71f4255 in QEventLoop::enterLoop (this=0x80e5808)
    at kernel/qeventloop.cpp:198
#82 0xa71f417a in QEventLoop::exec (this=0x80e5808)
    at kernel/qeventloop.cpp:145
#83 0xa71da38d in QApplication::exec (this=0xafc6c79c)
    at kernel/qapplication.cpp:2758
#84 0xa663d895 in kdemain (argc=1, argv=0x80b3558)
    at /home/sid-user/kdebase/kdebase-3.5.3/./konqueror/konq_main.cc:206
#85 0xa6694524 in kdeinitmain (argc=1, argv=0x80b3558) at konqueror_dummy.cc:3
#86 0x0804e216 in launch (argc=1, _name=0x80b33e4 "konqueror", 
    args=0x80b33ee "\001", cwd=0x0, envc=1, envs=0x80b33ff "", 
    reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x0)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:639
#87 0x0804e966 in handle_launcher_request (sock=8)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:1206
#88 0x0804ee23 in handle_requests (waitForPid=0)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:1407
#89 0x0804ffd2 in main (argc=3, argv=0xafc6d2b4, envp=0x0)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:1863
#90 0xa7cbbeb0 in __libc_start_main () from /lib/tls/libc.so.6
#91 0x0804b8a1 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 1 illogic-al 2006-06-21 06:12:02 UTC
confirmed. 
Comment 2 Tommi Tervo 2006-06-21 10:12:34 UTC

*** This bug has been marked as a duplicate of 128015 ***