Bug 129226 - favicon.ico is cached per host, not per (host, port)
Summary: favicon.ico is cached per host, not per (host, port)
Status: RESOLVED DUPLICATE of bug 124482
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 34 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-16 01:08 UTC by Jonas Kölker
Modified: 2009-02-04 14:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Kölker 2006-06-16 01:08:00 UTC
Version:           3.5.2 (using KDE KDE 3.5.3)
Installed from:    Debian testing/unstable Packages
Compiler:          gcc (GCC) 4.0.4 20060507 (prerelease) (Debian 4.0.3-3) 
OS:                Linux

Konqueror caches favicon.ico per host, not per (host, port) as it should.

To convince yourself that per (host, port) caching is The Right Thing (tm), go to 127.0.0.1:631 (cups config), then go to 127.0.0.1:80 (your pwn l33t w3bs1te with a favicon.ico and all).
Comment 1 Martin Fitzpatrick 2007-01-12 21:30:37 UTC
Confirmed this behaviour on KDE 3.5.5 / Kubuntu 6.10.
Comment 2 Martin Fitzpatrick 2008-04-07 23:29:01 UTC
Confirmed behaviour still exists in 4.0.3/Kubuntu. Not that you may need to save a bookmark to get it to show the favicon in the first instance.
Comment 3 Gustavo Narea 2008-06-08 16:43:43 UTC
Confirmed in KDE 4.1 Beta1/Kubuntu.
Comment 4 Jonathan Marten 2009-02-04 14:42:49 UTC

*** This bug has been marked as a duplicate of bug 124482 ***