Bug 128848 - KNode doesn't detect the signature delimiter when replying to GPG signed messages
Summary: KNode doesn't detect the signature delimiter when replying to GPG signed mess...
Status: RESOLVED WORKSFORME
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-08 19:39 UTC by Ritesh Raj Sarraf
Modified: 2016-11-25 16:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ritesh Raj Sarraf 2006-06-08 19:39:40 UTC
Version:           3.5.2 (using KDE KDE 3.5.3)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I doubt if Knode right now has this feature.
But I checked it in Kmail and Kmail does have it.

Knode is not stripping signatures while replying a message. I checked the messages and the signatures that were appended to it were proper i.e. double hyphen followed by a space.

I'm not sure if it's a feature request or knode misbehaving.
Comment 1 Stefan Borggraefe 2006-06-10 20:21:02 UTC
KNode also has this feature. Look harder in the settings dialog. I only have a German KNode running right now, so I can't tell you the English name of the option, but it is there.
Comment 2 Ritesh Raj Sarraf 2006-06-11 18:20:34 UTC
Okay!
I found more information which confirms that there is a bug.

If you use GPG to sign the messages you post/reply, your messages are not in proper order. In such messages the signature doesn't get stripped off because the signature delimiter is scrambled as (- --=20).

Re-opening the bug because GPG signing a message is a feature in Knode which isn't working properly.

Thanks,
Ritesh
Comment 3 Ritesh Raj Sarraf 2006-06-11 18:25:07 UTC
This has been a known issue for some time now. I wonder why anybody never responded to this bug report.
http://bugs.kde.org/show_bug.cgi?id=113838
Comment 4 Stefan Borggraefe 2006-06-11 19:50:03 UTC
Confirming.

KNode doesn't detect signature delimiters in dash escaped texts when replying.

See see RFC 2440, Section 7.1 (http://www.rfc-archive.org/getrfc.php?rfc=2440).
Comment 5 mark 2013-03-11 16:16:41 UTC
This still seems to be an open bug as kmail 4.10.1 likes to scramble GPG signed/encrypted mails - at least with larger text inside.