Bug 128830 - konqueror segfault because javascript crash on some script
Summary: konqueror segfault because javascript crash on some script
Status: RESOLVED DUPLICATE of bug 116092
Alias: None
Product: konqueror
Classification: Applications
Component: kjs (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-08 15:01 UTC by rapsys
Modified: 2006-06-18 00:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
DO NOT OPEN WITH KONQUEROR AND JAVASCRIPT ACTIVATED => full crash (103.12 KB, text/html)
2006-06-08 15:02 UTC, rapsys
Details
backtrace and gdb piece of call trace (10.62 KB, text/plain)
2006-06-08 15:03 UTC, rapsys
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rapsys 2006-06-08 15:01:27 UTC
Version:           3.5.3 (using KDE KDE 3.5.3)
Installed from:    Mandriva RPMs
Compiler:          gcc version 4.1.1 20060518 (prerelease) Configured with: ../configure --prefix=/usr --libexecdir=/usr/lib --with-slibdir=/lib --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --enable-languages=c,c++,ada,fortran,objc,obj-c++,java --host=i586-mandriva-linux-gnu --with-system-zlib --enable-long-long --enable-__cxa_atexit --enable-clocale=gnu --disable-libunwind-exceptions --enable-java-awt=gtk --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --enable-gtk-cairo --enable-ssp --disable-libssp
OS:                Linux

I was going on url : https://www.google.com/adsense/referrals-settings

And cpu reach 100% then after a few time, konqueror crash (no kdbg show to get the backtrace)

I have saved the file (and clean it from my login+id), see next attachement.

I am unable to produce a backtrace with gdb, as it want to display page and pages of backtrace calls...

See next attachement for crashing webpage
The second one is the konqueror backtrace with a single page of the gdb backtrace.

This is a critical bug (present on a well used website)
Comment 1 rapsys 2006-06-08 15:02:33 UTC
Created attachment 16526 [details]
DO NOT OPEN WITH KONQUEROR AND JAVASCRIPT ACTIVATED => full crash
Comment 2 rapsys 2006-06-08 15:03:10 UTC
Created attachment 16527 [details]
backtrace and gdb piece of call trace
Comment 3 Maksim Orlovich 2006-06-08 20:52:00 UTC
Thanks for the backtrace, there is a dupe with a simple bt someplace of this...
Comment 4 rapsys 2006-06-10 00:10:13 UTC
[bugs.kde.org quoted mail]
I hope it will be fixed soon...

Such crash on google website may be realy anoying...
Comment 5 rapsys 2006-06-10 05:12:02 UTC
I have an other crash (I think in the same cathegorie), but that time, it happen two time, but later I haven't been able to reproduce.
(If you may look if there is not a bug it whould be great)

The bug was openning page : http:/ /www.backbase.com
clicking on the link of the demo (user agent konqueror) makes the konqueror segfault.

See kdbg backtrace in next attachement
Comment 6 Maksim Orlovich 2006-06-18 00:51:25 UTC

*** This bug has been marked as a duplicate of 116092 ***