Bug 128638 - kded crash caused by signal SIGSEGV
Summary: kded crash caused by signal SIGSEGV
Status: RESOLVED DUPLICATE of bug 123315
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-04 21:33 UTC by Marijn Schouten
Modified: 2006-07-25 19:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marijn Schouten 2006-06-04 21:33:48 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    Gentoo Packages
Compiler:          gcc-4.1.1 
OS:                Linux

I was recompiling my Gentoo system and when I got back home I was greeted by the KDE Crash Handler for kded. Here's the backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47989206505248 (LWP 28914)]
[KCrash handler]
#5  0x00002ba559781d3b in operator== () from /usr/qt/3/lib64/libqt-mt.so.3
#6  0x00002ba557dde9b1 in KDirWatchPrivate::slotActivated ()
   from /usr/kde/3.5/lib64/libkio.so.4
#7  0x00002ba557ddebcd in KDirWatchPrivate::qt_invoke ()
   from /usr/kde/3.5/lib64/libkio.so.4
#8  0x00002ba5594ff38c in QObject::activate_signal ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#9  0x00002ba5594fff65 in QObject::activate_signal ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#10 0x00002ba559519acb in QSocketNotifier::event ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#11 0x00002ba5594a9295 in QApplication::internalNotify ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#12 0x00002ba5594a9e97 in QApplication::notify ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#13 0x00002ba55891229f in KApplication::notify ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#14 0x00002ba55949f49b in QEventLoop::activateSocketNotifiers ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#15 0x00002ba5594609a3 in QEventLoop::processEvents ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#16 0x00002ba5594bda72 in QEventLoop::enterLoop ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#17 0x00002ba5594bd922 in QEventLoop::exec ()
   from /usr/qt/3/lib64/libqt-mt.so.3
#18 0x00002ba557a8c0a4 in kdemain ()
   from /usr/kde/3.5/lib64/libkdeinit_kded.so
#19 0x00002ba55b7a3134 in __libc_start_main () from /lib/libc.so.6
#20 0x0000000000400769 in _start ()
Comment 1 Thiago Macieira 2006-06-11 01:04:39 UTC
How can we reproduce the problem?
Comment 2 Marijn Schouten 2006-06-12 10:47:18 UTC
I don't know how to reproduce this. I don't even know what kded is for. I thought the backtrace might be enough to tell what was going on.
Comment 3 Andreas Kling 2006-07-25 19:39:03 UTC

*** This bug has been marked as a duplicate of 123315 ***