Bug 128588 - Crash on DVD playback
Summary: Crash on DVD playback
Status: RESOLVED WORKSFORME
Alias: None
Product: kaffeine
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christophe Thommeret
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-03 23:19 UTC by Patrick Magowan
Modified: 2009-10-25 14:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Magowan 2006-06-03 23:19:14 UTC
Version:           0.7.1 (using KDE KDE 3.5.3)
Installed from:    Ubuntu Packages
Compiler:          GCC 4.0 
OS:                Linux

After inserting a DVD, the autoplay box pops up, I select Play DVD with Kaffeine.  Kaffeine begins to load the DVD and then it crashes.  Here is the backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232562496 (LWP 5982)]
[New Thread -1329415248 (LWP 5993)]
[New Thread -1313539152 (LWP 5991)]
[New Thread -1305146448 (LWP 5990)]
[New Thread -1296553040 (LWP 5989)]
[New Thread -1286272080 (LWP 5988)]
[New Thread -1273779280 (LWP 5987)]
[New Thread -1265116240 (LWP 5986)]
[New Thread -1256723536 (LWP 5985)]
[New Thread -1243919440 (LWP 5984)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb6afa2ae in __lll_mutex_lock_wait ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb6af6fbb in _L_mutex_lock_33 () from /lib/tls/i686/cmov/libpthread.so.0
#3  0xb7f5e711 in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#4  0xb6b6eeab in XUnlockDisplay () from /usr/lib/libX11.so.6
#5  0xb6b64ca5 in XFreeCursor () from /usr/lib/libX11.so.6
#6  0xb6fdb49f in QCursorData::~QCursorData () from /usr/lib/libqt-mt.so.3
#7  0xb6fdbab7 in QCursor::~QCursor () from /usr/lib/libqt-mt.so.3
#8  0xb6fdc7a5 in QCursor::setBitmap () from /usr/lib/libqt-mt.so.3
#9  0xb68de844 in __cxa_finalize () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6fbd2fb in ?? () from /usr/lib/libqt-mt.so.3
#11 0xb7568760 in ?? () from /usr/lib/libqt-mt.so.3
#12 0xb755a97c in ?? () from /usr/lib/libqt-mt.so.3
#13 0xbf96a938 in ?? ()
#14 0xb748149f in _fini () from /usr/lib/libqt-mt.so.3
#15 0xb748149f in _fini () from /usr/lib/libqt-mt.so.3
#16 0xb7f628f4 in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#17 0xb68de5d7 in exit () from /lib/tls/i686/cmov/libc.so.6
#18 0xb6fbd740 in qt_badwindow () from /usr/lib/libqt-mt.so.3
#19 0xb770a077 in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#20 0xb770a0b5 in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#21 0xb6b83cb7 in _XIOError () from /usr/lib/libX11.so.6
#22 0xb6b86527 in _XEventsQueued () from /usr/lib/libX11.so.6
#23 0xb6b72b58 in XPending () from /usr/lib/libX11.so.6
#24 0xb6fe44b3 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#25 0xb70588b7 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#26 0xb70587da in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#27 0xb703e8d5 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#28 0x0806cbc3 in ?? ()
#29 0xb68c7ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#30 0x08069511 in ?? ()
Comment 1 Pekka Luotolinna 2007-10-17 19:40:55 UTC
This problem still exists..
Comment 2 Lubos Lunak 2008-07-21 16:22:45 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 3 Dario Andres 2009-10-02 03:49:23 UTC
- Is this still happening with an updated version ?
Thanks
Comment 4 Christoph Pfister 2009-10-25 14:04:56 UTC
please reopen if this problem persists