Bug 128569 - cvs crash update save
Summary: cvs crash update save
Status: RESOLVED DUPLICATE of bug 123315
Alias: None
Product: kdevelop
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-03 16:04 UTC by Roberto Vera Alvarez
Modified: 2006-07-25 19:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Vera Alvarez 2006-06-03 16:04:33 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    SuSE RPMs
Compiler:          SuSE 10.1 RPMS 
OS:                Linux

Hi:
  I installed the SuSE Linux 10.1 in my computer with the default KDE 3.5.1.
  For this distro the Kdevelop version is the 3.3.1.

 I use a project in the Kdevelop with the extern CVS repository and I update a file into the CVS with the CvsService and reload the file into de Kdevelop, all these stuff work fine. The problem is when I modify the reloaded file from CVS and I try to save it. 

The Kdevelop crashed with signal 11 (SIGSEGV) and the window that show the copy of the file to the backup file, with ~ prefix, stay open without complete the transfer.

I update my system to KDE 3.5.3 and Kdevelop 3.3.3 and the problem stays. 

Best regards,
     Roberto.

I send you the trace from the KDE Crash Handler:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1240119632 (LWP 13673)]
[New Thread -1255859296 (LWP 13698)]
[KCrash handler]
#6  0xb742c839 in operator== (s1=@0x8e16dbc, s2=@0xbf8e805c)
    at tools/qstring.h:653
#7  0xb7d22010 in KDirWatchPrivate::slotActivated (this=0x8712b88)
    at ./kio/kio/kdirwatch.cpp:439
#8  0xb7d222bc in KDirWatchPrivate::qt_invoke (this=0x8712b88, _id=4, 
    _o=0xbf8e8134) at ./kio/kio/kdirwatch_p.moc:90
#9  0xb715cedd in QObject::activate_signal (this=0x87133a0, clist=0x8713c38, 
    o=0xbf8e8134) at kernel/qobject.cpp:2356
#10 0xb715da42 in QObject::activate_signal (this=0x87133a0, signal=2, param=12)
    at kernel/qobject.cpp:2449
#11 0xb74965f0 in QSocketNotifier::activated (this=0x87133a0, t0=12)
    at .moc/release-shared-mt/moc_qsocketnotifier.cpp:85
#12 0xb717b0e0 in QSocketNotifier::event (this=0x87133a0, e=0xbf8e83d8)
    at kernel/qsocketnotifier.cpp:258
#13 0xb70fdec7 in QApplication::internalNotify (this=0xbf8e944c, 
    receiver=0x87133a0, e=0xbf8e83d8) at kernel/qapplication.cpp:2636
#14 0xb70fec91 in QApplication::notify (this=0xbf8e944c, receiver=0x87133a0, 
    e=0xbf8e83d8) at kernel/qapplication.cpp:2359
#15 0xb77b9633 in KApplication::notify (this=0xbf8e944c, receiver=0x87133a0, 
    event=0xbf8e83d8) at ./kdecore/kapplication.cpp:552
#16 0xb70f2b04 in QEventLoop::activateSocketNotifiers (this=0x80a5908)
    at kernel/qapplication.h:520
#17 0xb70ad7d4 in QEventLoop::processEvents (this=0x80a5908, flags=4)
    at kernel/qeventloop_x11.cpp:383
#18 0xb7114ce8 in QEventLoop::enterLoop (this=0x80a5908)
    at kernel/qeventloop.cpp:198
#19 0xb70fd9ef in QApplication::enter_loop (this=0xbf8e944c)
    at kernel/qapplication.cpp:2794
#20 0xb7c3cb75 in KIO::NetAccess::enter_loop (this=0xbf8e86a0)
    at ./kio/kio/netaccess.cpp:498
#21 0xb7c85e2a in KIO::NetAccess::filecopyInternal (this=0xbf8e86a0, 
    src=@0xbf8e88f4, target=@0xbf8e87dc, permissions=420, overwrite=true, 
    resume=false, window=0x811cc08, move=false) at ./kio/kio/netaccess.cpp:316
#22 0xb7c86125 in KIO::NetAccess::file_copy (src=@0xbf8e88f4, 
    target=@0xbf8e87dc, permissions=420, overwrite=true, resume=false, 
    window=0x811cc08) at ./kio/kio/netaccess.cpp:127
#23 0xb4982c8c in KateDocument::save (this=0x8d222f0)
    at ./kate/part/katedocument.cpp:2464
#24 0xb7f0c434 in PartController::saveFile (this=0x8168588, url=@0xbf8e8a44, 
    force=false) at partcontroller.cpp:1021
#25 0xb7f0c7b9 in PartController::slotSave (this=0x8168588)
    at partcontroller.cpp:958
#26 0xb7f0d4cd in PartController::qt_invoke (this=0x8168588, _id=9, 
    _o=0xbf8e8b18) at partcontroller.moc:161
#27 0xb715cedd in QObject::activate_signal (this=0x8dec560, clist=0x8d38250, 
    o=0xbf8e8b18) at kernel/qobject.cpp:2356
#28 0xb715db3d in QObject::activate_signal (this=0x8dec560, signal=2)
    at kernel/qobject.cpp:2325
#29 0xb7973819 in KAction::activated (this=0x8dec560)
    at ./kdeui/kaction.moc:176
#30 0xb79a8a22 in KAction::slotActivated (this=0x8dec560)
    at ./kdeui/kaction.cpp:1113
#31 0xb79a89bc in KAction::slotButtonClicked (this=0x8dec560, state=LeftButton)
    at ./kdeui/kaction.cpp:1158
#32 0xb7a7b146 in KAction::qt_invoke (this=0x8dec560, _id=17, _o=0xbf8e8c20)
    at ./kdeui/kaction.moc:220
#33 0xb715cedd in QObject::activate_signal (this=0x8da0a78, clist=0x8e658d8, 
    o=0xbf8e8c20) at kernel/qobject.cpp:2356
#34 0xb79ad820 in KToolBarButton::buttonClicked (this=0x8da0a78, t0=-52, 
    t1=LeftButton) at ./kdeui/ktoolbarbutton.moc:154
#35 0xb79adb26 in KToolBarButton::mouseReleaseEvent (this=0x8da0a78, 
    e=0xbf8e90b4) at ./kdeui/ktoolbarbutton.cpp:479
#36 0xb7195c00 in QWidget::event (this=0x8da0a78, e=0xbf8e90b4)
    at kernel/qwidget.cpp:4702
#37 0xb7a23d31 in KToolBarButton::event (this=0x2e0062, e=0x1)
    at ./kdeui/ktoolbarbutton.cpp:651
#38 0xb70fdec7 in QApplication::internalNotify (this=0xbf8e944c, 
    receiver=0x8da0a78, e=0xbf8e90b4) at kernel/qapplication.cpp:2636
#39 0xb70fedfb in QApplication::notify (this=0xbf8e944c, receiver=0x8da0a78, 
    e=0xbf8e90b4) at kernel/qapplication.cpp:2422
#40 0xb77b9633 in KApplication::notify (this=0xbf8e944c, receiver=0x8da0a78, 
    event=0xbf8e90b4) at ./kdecore/kapplication.cpp:552
#41 0xb709ddd2 in QETWidget::translateMouseEvent (this=0x8da0a78, 
    event=0xbf8e9358) at kernel/qapplication.h:523
#42 0xb709cfa6 in QApplication::x11ProcessEvent (this=0xbf8e944c, 
    event=0xbf8e9358) at kernel/qapplication_x11.cpp:3565
#43 0xb70ad5ea in QEventLoop::processEvents (this=0x80a5908, 
    flags=<value optimized out>) at kernel/qeventloop_x11.cpp:192
#44 0xb7114ce8 in QEventLoop::enterLoop (this=0x80a5908)
    at kernel/qeventloop.cpp:198
#45 0xb7114b7e in QEventLoop::exec (this=0x80a5908)
    at kernel/qeventloop.cpp:145
#46 0xb70fda7f in QApplication::exec (this=0xbf8e944c)
    at kernel/qapplication.cpp:2759
#47 0x0804de7e in main (argc=) at main.cpp:145
Comment 1 Andreas Kling 2006-07-25 19:48:20 UTC

*** This bug has been marked as a duplicate of 123315 ***