Bug 128462 - EXIF Info is empty, in picture properties dialog only the exif-tag names are show, no values shown
Summary: EXIF Info is empty, in picture properties dialog only the exif-tag names are ...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Exif (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR grave with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-01 22:10 UTC by Manuel Koch
Modified: 2021-04-25 08:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.3.0


Attachments
Snapshot of picture properties dialog ( EXIF tab ) (404.58 KB, image/png)
2006-06-01 22:13 UTC, Manuel Koch
Details
Debian exif related package versions (11.46 KB, text/plain)
2006-06-05 11:34 UTC, Manuel Koch
Details
Example picture where EXIF values are not shown (788.87 KB, image/jpeg)
2006-06-05 20:54 UTC, Manuel Koch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Koch 2006-06-01 22:10:37 UTC
Version:           0.8.2-rc1 (using KDE KDE 3.5.3)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I'm using didkam with german translation.
Open album
- Select picture
- Right-Click, select "Properties" ( de=Eigenschaften )
- Selecting EXIF tab
I can see a lot of exif-tag names/descriptions but not the corresponding
tag-value. Hover mouse over tag or double clicking tag does not show
any value(s).
Comment 1 Manuel Koch 2006-06-01 22:13:37 UTC
Created attachment 16409 [details]
Snapshot of picture properties dialog ( EXIF tab )
Comment 2 Peter Yellman 2006-06-05 01:03:28 UTC
I have this exact same problem, same platform (Debian testing), same version of Digikam (0.8.2-rc1).  Started some time the most recent apt-get update, about May 31, 2006. The funny thing is, the problem did not manifest right away.  The chain of events went something like this: (1) After the update, everything was working fine, exif properties displaying.  (2) I plugged in my brand new camera, a Panasonic DMC-FZ7, into the USB port for the first time, although I had previously imported a few pictures from the new camera using an external card reader the day before.  I found that the camera is not fully supported by Digikam, which sees it as a Panasonic DMC-FZ20 (alternate id), and cannot import pictures.  The files are, however, accessible through Konqueror/file system (under /media/sdb1), so I pointed Digikam there and imported the pictures. (3) I realized the camera date/time was off by 12 hours, so I retrieved jhead and used it to batch modify the exif datetime to the correct time, then re-imported the pictures into Digikam.  (4) Very shortly thereafter, exif properties (for all my pictures) no longer displayed, as described by the original reporter.

Perhaps it needs to be submitted in the appropriate Debian bug reporting system.
Comment 3 Manuel Koch 2006-06-05 11:34:06 UTC
Created attachment 16487 [details]
Debian exif related package versions 

I grep'ed my installed debian packages containing "exif" string
( dpkg --search exif ) and checked their version ( dpkg --status XXX ).
Comment 4 caulier.gilles 2006-06-05 20:22:54 UTC
The problem can be in libexif or libkexif. 

If you have a picture with this problem, please post it in this room, i will trying to reproduce it...

Gilles
Comment 5 Manuel Koch 2006-06-05 20:54:39 UTC
Created attachment 16494 [details]
Example picture where EXIF values are not shown

Actually the problem occures with every of my pictures. This attached one is
just a example.
Comment 6 Peter Yellman 2006-06-05 22:53:23 UTC
>If you have a picture with this problem, please post it

As above, all pictures have this problem (in Digikam).  I have pictures from at least 5 different digital cameras in my Digikam collection, none are showing exif info.

>The problem can be in libexif or libkexif.

Right - is there anyway I can help narrow it down to just one?

dpkg -l libexif12
ii  libexif12          0.6.13-4           library to parse EXIF files
dpkg -l libkexif1
ii  libkexif1          0.2.3-1            library for KDE to read/display/edit 

Other programs which depend on libexif12 (such as exif) can display exif info, and programs which depend on libkexif1 (such as showimg) also can show exif info. Also, Konqueror displays exif metadata.  showFoto, obviously, is failing to show exif info.

It may be coincidence only, but I noticed some generalized "font weirdness" on my desktop and in some programs in the same session as when this problem with Digikam cropped up, fairly soon after apt-get update.  As I thought Digikam might have an problem actually displaying the text, I looked into my font configuration and it was the first time I noticed that display/use of bitmap fonts is now turned off by default in fontconfig (30-debconf-no-bitmaps.conf --> no-bitmaps.conf).  I understand this is a fairly recent change, and it may have been the first time I was using the version where bitmaps are off by default.  I toggled that setting a couple of times, finally leaving it on because I still want bimapped fonts.
Comment 7 Mark Purcell 2006-06-13 05:53:44 UTC
> Versions of packages digikam depends on:
...
>    ii  libkexif1  0.2.3-1      library for KDE to read/display/ed

I can confirm that this is a problem with version 0.2.3 of libkexif, if you 
downgrade libkexif to 0.2.2 then digikam again displays exif tags correctly.

Unfortunately we didn't catch this before libkexif migrated into testing, but 
you can find it at:
deb http://snapshot.debian.net/archive pool libkexif
Comment 8 Tom Albers 2006-06-13 10:09:43 UTC
Setting it to kipi-plugins, as that is the right mailinglist for this (please move it the next time as not all kipi-members are subscribed to digikam bugs). We have to fix this before a release. Is anyone working on it? Really nasty. Did anyone test with another host app?
Comment 9 Angelo Naselli 2006-06-18 17:11:49 UTC
SVN commit 552622 by anaselli:

missed mValue 
BUG: 128462

 M  +1 -1      kexifentry.cpp  


--- trunk/extragear/libs/libkexif/kexifentry.cpp #552621:552622
@@ -104,7 +104,7 @@
     exif_entry_get_value(mExifEntry, cstr.data(), cstr.size()-1);
     // just in case we don't get a null-terminated string
     cstr[cstr.size()-1] = '\0';
-    QString str = QString::fromLatin1(cstr.data());
+    mValue = QString::fromLatin1(cstr.data());
 #else
     mValue = QString::fromUtf8(exif_entry_get_value(mExifEntry));
 #endif
Comment 10 caulier.gilles 2006-06-19 15:29:18 UTC
Patch tested with digikam 0.8.2-rc2. Work fine !

Thanks Angelo (:=)))

Gilles
Comment 11 caulier.gilles 2021-04-25 08:25:13 UTC
Problem is no longer reproducible with digiKam 7.3.0 and Exiv2 0.27.4