Bug 128341 - Html export should not resize images if "resize target images" is not checked
Summary: Html export should not resize images if "resize target images" is not checked
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-HTMLGallery (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-31 04:03 UTC by CSights
Modified: 2017-07-09 07:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CSights 2006-05-31 04:03:01 UTC
Version:           0.8.1 (using KDE KDE 3.5.2)
Installed from:    Gentoo Packages
Compiler:          gcc v3.4 
OS:                Linux

Hi,
  In the HTML export wizard of digikam there is a checkbox under "Album" labeled "Resize target images".  When this is unchecked, I expect the original image file to be copied to "images" folder.
 
Instead the files appearing here are smaller than the originals, so they were clearly "Resized".

Thanks for the nice program!

C.
Comment 1 Angelo Naselli 2006-06-02 17:26:03 UTC
Not really :) The file size could increase if you use 100% of quality.
Anyway I believe the Resize flag should change the pixel format If I understood
well default is 1024xYYY or XXXx1024. So this seems to be the workforme.
Moreover the quality change the initial file anyway. So I change this bug to wishlist, because we could think a way to keep original files into html gallery.
 
   Angelo
Comment 2 Angelo Naselli 2006-06-03 15:29:24 UTC
*** Bug 116224 has been marked as a duplicate of this bug. ***
Comment 3 Aurelien Gateau 2006-11-09 19:00:44 UTC
SVN commit 603670 by gateau:

Reworked image and XML generation.
Added an option to use the original file.
BUG: 128341


 M  +94 -67    generator.cpp  
 M  +4 -0      htmlexportconfig.kcfg  
 M  +317 -204  imagesettingspage.ui  
Comment 4 caulier.gilles 2017-07-09 07:30:35 UTC
Problem is not reproducible with current HTML Gallery tool implemented in
digiKam core version 5.7.0

Gilles Caulier