Bug 127971 - Hard Drive device icons do not show on desktop 3.5.3
Summary: Hard Drive device icons do not show on desktop 3.5.3
Status: CLOSED FIXED
Alias: None
Product: kdesktop
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 101 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-24 21:19 UTC by texstar
Modified: 2009-01-02 20:32 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description texstar 2006-05-24 21:19:33 UTC
Version:           kdebase (using KDE KDE 3.5.3)
Installed from:    Compiled From Sources
OS:                Linux

KDEbase 3.5.3 does not show hard drive partition icons on the desktop even though they are checked in kcontrol.

However if you plug in a usbkey disk then the usbkey shows and the hard drive partition icons suddenly pop on the desktop. 

KDEbase 3.5.2 does not exhibit this behaviour.
Comment 1 texstar 2006-05-28 15:57:49 UTC
Followup: If you compile kdebase without hal/dbus backend then hard drive icons show as intended. 
Comment 2 stspi 2006-06-14 09:53:36 UTC
... but I do not want to compile it without hal/dbus backend.
If I mount or unmount any device, all other device icons pop on the desktop.

Should that be a feature?
Comment 3 Thomas Bettler 2006-06-19 23:46:26 UTC
I confirm this behaviour changed with kde 3.5.3 and wasn't there in 3.5.2

Strange. media:/ works fine, but the device icons are missing on the desktop, 
UNTIL you plug in some USB-Stick.
Comment 4 Ron Pepper 2006-06-20 00:53:51 UTC
My experience is the same as Thomas Bettler's. I'm using Debian (Kanotix) and always had device icons visible on the desktop (and checked in Control Center) until kde 3.5.3. Like others, my hd device icons pop up if I plug in a USB-stick.
Comment 5 David Hubner 2006-06-20 05:17:36 UTC
I also have this bug on kde 3.5.3 and using todays ( 20/6/06 ) SVN does not fix it.

Hal version -  0.5.7 
Dbus version - 0.61 

It did not exist on kde 3.5.2.
Comment 6 Alexander 2006-06-20 16:44:44 UTC
Same problem with KDE 3.5.3, debian testing/unstable. With 3.5.2 all was allright.
Comment 7 Michał Kosmulski 2006-06-20 17:48:20 UTC
Confirming problem on Slackware (which doesn't have HAL). After I upgraded to KDE 3.5.3, all my device icons disappeared from the desktop. However, if I mount some device, e.g. the CD-ROM for example by using the 'devices' tab in konqueror's sidebar, all device icons reappear (not only the mounted one). I also noticed that toggling 'Enable CD polling' in Control Center -> Storage Media (I only checked for changing from On to Off state so far) has the same effect - device icons on the desktop reappear. Could this issue somehow be related to #118216 ?
Comment 8 Alexander 2006-06-21 13:31:43 UTC
Tried to delete folder ~/.kde/share/config - no results. So problem with kde. Please, fix this bug.
Comment 9 Benjamin Park 2006-06-21 19:32:47 UTC
I believe that it's related to bugs #110304 and #118216.

I confirm the problem using debian sid (actually, Kanotix)
See these posts in the Kanotix forum:
http://kanotix.com/index.php?name=PNphpBB2&file=viewtopic&t=18597&highlight=
http://kanotix.com/index.php?name=PNphpBB2&file=viewtopic&t=18934&highlight=

Comment 10 Benjamin Park 2006-06-21 20:49:23 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 Michał Kosmulski 2006-06-25 12:46:11 UTC
Here are some more observations with regards to 'Enable CD polling' option and possible relation to bug #118216. I had this option turned off when logging out of KDE. After just logging in into KDE, turning this option on enables device icons on the desktop and turning it off again disables it once more. However, if I log out when the option is enabled, after logging back in, I need to toggle this option again in order to make icons visible.
Comment 12 Adrian Dannberg 2006-07-01 16:13:56 UTC
Similar bug here on gentoo kde-3.5.3-r2

My DVD icon does not appear on the desktop. Pluging in a USBpen, doesn't make the icon appear.
Icons for hard drive volumes (partitions) are working, besides the fact that kde recognizes my, of course mounted, / als unmounted.
Comment 13 Proteus Polyeides 2006-07-08 14:23:49 UTC
Roger that. Same happens on Gentoo with KDE 3.5.3. After i start kde no device icons are shown on desktop, althought some were mounted earlier. After mounting any device under KDE, all appear at once. Same happens after relogging into KDE.

hal - 0.5.7
dbus - 0.62
udev - 0.94
Comment 14 Lubos Lunak 2006-07-10 20:00:14 UTC
SVN commit 560584 by lunakl:

Load mediamanager kded module soon in the startup. It used
to do notification about new media after startup, but that was
removed (r468233) even before the startup reorder because it was
a noticeable part of the startup time for some reason. The module
should be loaded soon anyway because media icons can be shown
on the desktop.
BUG: 127971
BUG: 129534



 M  +1 -0      mediamanager.desktop  


--- branches/KDE/3.5/kdebase/kioslave/media/mediamanager/mediamanager.desktop #560583:560584
@@ -120,3 +120,4 @@
 X-KDE-FactoryName=mediamanager
 X-KDE-Kded-autoload=true
 X-KDE-Kded-load-on-demand=true
+X-KDE-Kded-phase=1
Comment 15 Benjamin Park 2006-07-10 23:18:49 UTC
Someone posted a (perhaps temporary) fix on the Kanotix forums:

http://kanotix.com/index.php?name=PNphpBB2&file=viewtopic&p=121503#121503

by feffer777:

"Based on his (Lubos Lunak's) comment I opened the mediamanager.desktop file which I found on the path /usr/share/services/kded/mediamanager.desktop and at the bottom added this line:

     X-KDE-Kded-phase=1

and after it, a carriage return."
Comment 16 stspi 2006-07-11 10:44:00 UTC
...thx, this works for me.
On gentoo you will find this file in /usr/kde/3.5/share/services/kded/
Comment 17 Michał Kosmulski 2006-07-11 21:33:57 UTC
Thanks for the workaround, it worked for me. On Slackware, the relevant file is /opt/kde/share/services/kded/mediamanager.desktop
Comment 18 FiNeX 2009-01-02 20:32:37 UTC
Bug closed. Kdesktop is no more mantained.