Bug 127763 - color management, profile selection crashes
Summary: color management, profile selection crashes
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-ColorManagement (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-21 13:08 UTC by Daniel Bauer
Modified: 2017-08-06 21:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.0


Attachments
crash manager messages after click "info" with no profile selected (134.32 KB, text/plain)
2006-05-21 13:09 UTC, Daniel Bauer
Details
crash manager text after selecting input profile for workspace (85.95 KB, text/plain)
2006-05-21 13:10 UTC, Daniel Bauer
Details
console output of gdb digikam (11.25 KB, text/plain)
2006-06-03 19:13 UTC, Daniel Bauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bauer 2006-05-21 13:08:38 UTC
Version:           0.9.0 svn (using KDE KDE 3.5.2)
Installed from:    SuSE RPMs
OS:                Linux

digikam crashes when in color->color management
- click on the info-button in the workspace tab, when no profile is selected
- trying to select a wrong profile (i.e. a input profile for workspace), 

to reproduce second case: 
marked "default" in input tab (EOS 10D linear@lysator.liu.se)
marked "selected profile" in workspace tab, then select fuji1.icm (or another input device profile) 
click "Versuch"-button ("try?")

I'll attach the messages from kde crash manager
Comment 1 Daniel Bauer 2006-05-21 13:09:51 UTC
Created attachment 16200 [details]
crash manager messages after click "info" with no profile selected
Comment 2 Daniel Bauer 2006-05-21 13:10:51 UTC
Created attachment 16201 [details]
crash manager text after selecting input profile for workspace
Comment 3 F.J. Cruz 2006-06-03 16:30:56 UTC
The backtrace from the crash manager hasn't any info, so it's useless. Maybe, you can get some feedback with:

>gdb digikam
>run
.
.
.
<crash>
> bt

In any case, I'm going to reproduce this bug.

Paco
Comment 4 Daniel Bauer 2006-06-03 19:11:35 UTC
Not sure if my info helps anything, because it seems that I have not been able 
to make a correct svn install in addition to my existing 0.8.1. So the "bug" 
is maybe specific only to my "wrong install"...

However, after the latest svn update:

- "crash after click on the info-button in the workspace tab, when no profile 
is selected"
seems solved now (a message "...there isn't any ... profile" appears, no crash 
anymore)

- "crash after trying to select a wrong profile" still exists on my install:

in "color management" I've chosen 
for input: "selected profile" (eos10d-linear-8apr2004.icc)
for workspace: "selected profile" (EOS 10D.icc)
click "Versuch": crash

I'll send output of gdb as attachement.

Daniel
Comment 5 Daniel Bauer 2006-06-03 19:13:26 UTC
Created attachment 16453 [details]
console output of gdb digikam
Comment 6 F.J. Cruz 2006-06-03 23:06:55 UTC
El Sábado, 3 de Junio de 2006 19:11, Daniel Bauer escribió:
[bugs.kde.org quoted mail]

Don't worry Daniel, I've reproduced both of them.

The first happened under some conditions, but now it's fixed (I think).

Actually, I'm working to fix the second.

Paco Cruz
Comment 7 F.J. Cruz 2006-06-24 16:26:30 UTC
This bug is going to be closed, as the SVN commit #554521 seems to fix it.
Comment 8 F.J. Cruz 2006-06-24 16:27:02 UTC
*** Bug has been marked as fixed ***.