Bug 127701 - konqueror crashes on exit
Summary: konqueror crashes on exit
Status: RESOLVED DUPLICATE of bug 119512
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-20 10:37 UTC by Andre Woebbeking
Modified: 2006-05-20 10:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Woebbeking 2006-05-20 10:37:14 UTC
Version:           3.5.2 (using KDE 3.5.2, compiled sources)
Compiler:          Target: x86_64-linux-gnu
OS:                Linux (x86_64) release 2.6.16-1-amd64-k8

Hi,

maybe crash is not correct as it's about an assert():

#5  0x00002b8791d3bde0 in raise () from /lib/libc.so.6
#6  0x00002b8791d3d290 in abort () from /lib/libc.so.6
#7  0x00002b8791d34ffb in __assert_fail () from /lib/libc.so.6
#8  0x00002b8793faaff5 in khtml::Cache::clear ()
    at /Devel/src/kde/kdelibs/khtml/misc/loader.cpp:1277
#9  0x00002b8793eb1cbe in ~KHTMLFactory (this=0x9f8690)
    at /Devel/src/kde/kdelibs/khtml/khtml_factory.cpp:98
#10 0x00002b8793eb185b in KHTMLFactory::deref ()
    at /Devel/src/kde/kdelibs/khtml/khtml_factory.cpp:139
#11 0x00002b8793eb1cd5 in ~KHTMLFactory (this=0x4e95)
    at /Devel/src/kde/kdelibs/khtml/khtml_factory.cpp:103
#12 0x00002b878f2e933f in ~KLibrary (this=0x9f6220)
    at /Devel/src/kde/kdelibs/kdecore/klibloader.cpp:131
#13 0x00002b878f2e9851 in KLibLoader::close_pending (this=0x7360b0, 
    wrap=<value optimized out>)
    at /Devel/src/kde/kdelibs/kdecore/klibloader.cpp:516
#14 0x00002b878f2ea504 in ~KLibLoader (this=0x7360b0)
    at /Devel/src/kde/kdelibs/kdecore/klibloader.cpp:328
#15 0x00002b878f2e88b6 in KLibLoader::cleanUp ()
    at /Devel/src/kde/kdelibs/kdecore/klibloader.cpp:298
#16 0x00002b878f2610ce in ~KApplication (this=0x7fffffb196e0)
    at /Devel/src/kde/kdelibs/kdecore/kapplication.cpp:1609
#17 0x00002b87928ea0c7 in kdemain (argc=<value optimized out>, 
    argv=<value optimized out>)
    at /Devel/src/kde/kdebase/konqueror/konq_main.cc:221
#18 0x0000000000408541 in launch (argc=4, _name=0x5d6f88 "konqueror", 
    args=0x5d6fca "/home/almer", cwd=0x5d6fca "/home/almer", envc=27, 
    envs=0x5d738f "", reset_env=true, tty=0x0, avoid_loops=false, 
    startup_id_str=0x5d7397 "saturn;1148108748;604461;4950_TIME1352480028")
    at /Devel/src/kde/kdelibs/kinit/kinit.cpp:639
#19 0x0000000000408ce7 in handle_launcher_request (sock=4)
    at /Devel/src/kde/kdelibs/kinit/kinit.cpp:1206
#20 0x00000000004092b5 in handle_requests (waitForPid=0)
    at /Devel/src/kde/kdelibs/kinit/kinit.cpp:1397
#21 0x0000000000409be2 in main (argc=3, argv=0x1, envp=0x7fffffb1a898)
    at /Devel/src/kde/kdelibs/kinit/kinit.cpp:1863


Cheers,
André
Comment 1 Tommi Tervo 2006-05-20 10:44:38 UTC

*** This bug has been marked as a duplicate of 119512 ***

*** This bug has been marked as a duplicate of 119512 ***