Bug 127540 - extra character (^L) in konsolepart when using bash vi mode
Summary: extra character (^L) in konsolepart when using bash vi mode
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 130094 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-18 01:01 UTC by Simon Perreault
Modified: 2006-07-04 14:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Perreault 2006-05-18 01:01:49 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Ubuntu Packages

Add "set -o vi" to your .bashrc file. Now start any program using the Konsole kpart. You'll see that the first letter you type is preceded by a ^L character, which is annoying. Konsole itself doesn't have this problem, only the kpart does.
Comment 1 Kurt Hindenburg 2006-05-27 20:23:24 UTC
Confirmed on 1.6.3

set -o vi
vi      Use a vi-style command line editing interface.
Comment 2 Andreas Kling 2006-07-01 17:41:15 UTC
*** Bug 130094 has been marked as a duplicate of this bug. ***
Comment 3 Kurt Hindenburg 2006-07-04 14:35:13 UTC
SVN commit 557931 by hindenburg:

Fix extra character (^L) in konsolepart when using bash vi mode.  This has been in since at least KDE 3.3.0, which is the earliest I have.

BUG: 127540


 M  +1 -2      konsole_part.cpp  


--- branches/KDE/3.5/kdebase/konsole/konsole/konsole_part.cpp #557930:557931
@@ -1049,7 +1049,7 @@
 void konsolePart::startProgram( const QString& program,
                                 const QStrList& args )
 {
-    kdDebug(1211) << "konsolePart::startProgram for " << program << endl;
+//    kdDebug(1211) << "konsolePart::startProgram for " << program << endl;
     if ( !se )
         newSession();
     se->setProgram( program, args );
@@ -1090,7 +1090,6 @@
   connect( se, SIGNAL( destroyed() ), this, SLOT( sessionDestroyed() ) );
 //  setFont( n_font ); // we do this here, to make TEWidget recalculate
                      // its geometry..
-  te->emitText( QString::fromLatin1( "\014" ) );
 }
 
 void konsolePart::showShellInDir( const QString& dir )
Comment 4 Kurt Hindenburg 2006-07-04 14:37:46 UTC
SVN commit 557933 by hindenburg:

Fix extra character (^L) in konsolepart when using bash vi mode.

CCBUG: 127540


 M  +0 -1      konsole_part.cpp  


--- trunk/KDE/kdebase/apps/konsole/konsole/konsole_part.cpp #557932:557933
@@ -1096,7 +1096,6 @@
   connect( se, SIGNAL( destroyed() ), this, SLOT( sessionDestroyed() ) );
 //  setFont( n_font ); // we do this here, to make TEWidget recalculate
                      // its geometry..
-  te->emitText( QLatin1String( "\014" ) );
 }
 
 void konsolePart::showShellInDir( const QString& dir )