Bug 127370 - kmail crashes on searching a just deleted message on IMAP
Summary: kmail crashes on searching a just deleted message on IMAP
Status: RESOLVED DUPLICATE of bug 113885
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: FreeBSD Ports FreeBSD
: NOR crash with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-15 17:17 UTC by Mark Martinec
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Martinec 2006-05-15 17:17:43 UTC
Version:           1.9.1 (using KDE KDE 3.5.2)
Installed from:    FreeBSD Ports
Compiler:          gcc version 3.4.4 [FreeBSD] 20050518 
OS:                FreeBSD

With folder on an IMAP server, a search that would find a just-deleted
message causes a crash. To reproduce:

- prepare two messages in any folder, e.g. in inbox,
  subjects "test1" and "test2";
- open the first message "test1", delete it;
- search by subject "test" (which should find
  "test2", and matches also the just deleted "test1")
- bingo, a crash every time

Mark
Comment 1 Magnus Holmgren 2006-05-16 10:19:45 UTC
Happens here too.
Comment 2 Mark Martinec 2006-10-24 17:31:40 UTC
Still on 1.9.4 (KDE 3.5.4), happens twice every day
when I'm not careful enough to avoid a sequence of actions
leading to a crash, very annoying.
Comment 3 Michael Seiwert 2006-11-01 08:11:59 UTC
It is reproducible please see pasted bt. 
Comment 4 Michael Seiwert 2006-11-01 08:12:44 UTC
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1250130256 (LWP 23547)]
[New Thread -1281270880 (LWP 23551)]
[New Thread -1272878176 (LWP 23550)]
[New Thread -1264485472 (LWP 23549)]
[New Thread -1256092768 (LWP 23548)]
[KCrash handler]
#5  0xffffe410 in __kernel_vsyscall ()
#6  0xb57fb7d0 in raise () from /lib/libc.so.6
#7  0xb57fcea3 in abort () from /lib/libc.so.6
#8  0xb57f501b in __assert_fail () from /lib/libc.so.6
#9  0xb7e0bde6 in KMFolderSearch::addSerNum (this=0x8a24f78, serNum=0)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldersearch.cpp:436
#10 0xb7e0fa5f in KMFolderSearch::qt_invoke (this=0x8a24f78, _id=17, 
    _o=0xbfb72228)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldersearch.moc:293
#11 0xb5f12f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0xb7e0a518 in KMSearch::found (this=0x85577b0, t0=0)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldersearch.moc:114
#13 0xb7e0d097 in KMSearch::slotSearchFolderResult (this=0x85577b0, 
    folder=0x8175710, serNums=@0xbfb722e8, pattern=0x896a2d8, complete=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldersearch.cpp:276
#14 0xb7e0d2f3 in KMSearch::qt_invoke (this=0x85577b0, _id=4, _o=0xbfb7236c)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldersearch.moc:128
#15 0xb5f12f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb7c9c18b in FolderStorage::searchResult (this=0x8175908, t0=0x8175710, 
    t1=@0xbfb7240c, t2=0x896a2d8, t3=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/folderstorage.moc:431
#17 0xb7d2e929 in KMFolderImap::slotSearchDone (this=0x8175908, 
    serNums=@0xbfb724a8, pattern=0x896a2d8, complete=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.cpp:2245
#18 0xb7d38e87 in KMFolderImap::qt_invoke (this=0x8175908, _id=19, 
    _o=0xbfb72530)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.moc:312
#19 0xb5f12f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb7e9a758 in KMail::SearchJob::searchDone (this=0x835f6c0, 
    t0=@0xbfb725e4, t1=0x896a2d8, t2=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/searchjob.moc:137
#21 0xb7e9b418 in KMail::SearchJob::slotSearchFolder (this=0x835f6c0)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/searchjob.cpp:227
#22 0xb7e9bb72 in KMail::SearchJob::qt_invoke (this=0x835f6c0, _id=2, 
    _o=0xbfb726e4)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/searchjob.moc:158
#23 0xb5f12e81 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb7d2e1fe in KMFolderImap::folderComplete (this=0x8175908, t0=0x8175908, 
    t1=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.moc:270
#25 0xb7d2e3a4 in KMFolderImap::finishMailCheck (this=0x8175908, 
    state=KMFolderImap::imapFinished)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.cpp:2313
#26 0xb7d2f756 in KMFolderImap::getMessagesResult (this=0x8175908, 
    job=0x8bd40a8, lastSet=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.cpp:1630
#27 0xb7d2f7da in KMFolderImap::slotGetLastMessagesResult (this=0x8175908, 
    job=0x8bd40a8)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.cpp:1639
#28 0xb7d391cc in KMFolderImap::qt_invoke (this=0x8175908, _id=30, 
    _o=0xbfb728a4)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.moc:323
#29 0xb5f12f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb6ab60de in KIO::Job::result () from /opt/kde35/lib/libkio.so.4
#31 0xb6abad6d in KIO::Job::emitResult () from /opt/kde35/lib/libkio.so.4
#32 0xb6abaede in KIO::SimpleJob::slotFinished ()
   from /opt/kde35/lib/libkio.so.4
#33 0xb6ac2e9d in KIO::TransferJob::slotFinished ()
   from /opt/kde35/lib/libkio.so.4
#34 0xb6ab90ea in KIO::TransferJob::qt_invoke ()
   from /opt/kde35/lib/libkio.so.4
#35 0xb5f12f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb5f13b7d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb6aa532c in KIO::SlaveInterface::finished ()
   from /opt/kde35/lib/libkio.so.4
#38 0xb6aa7a45 in KIO::SlaveInterface::dispatch ()
   from /opt/kde35/lib/libkio.so.4
#39 0xb6aa620a in KIO::SlaveInterface::dispatch ()
   from /opt/kde35/lib/libkio.so.4
#40 0xb6aa2e6c in KIO::Slave::gotInput () from /opt/kde35/lib/libkio.so.4
#41 0xb6aa3010 in KIO::Slave::qt_invoke () from /opt/kde35/lib/libkio.so.4
#42 0xb5f12f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb5f13a82 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb624c8f0 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0xb5f31120 in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb5eb3f07 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0xb5eb4cd1 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb64fbae2 in KApplication::notify () from /opt/kde35/lib/libkdecore.so.4
#49 0xb5ea8b44 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb5e63814 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb5ecad28 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0xb5ecabbe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#53 0xb5eb3abf in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#54 0x0804a90f in main (argc=7, argv=0xbfb73644)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/main.cpp:110
Comment 5 Tommi Tervo 2006-11-01 10:50:04 UTC

*** This bug has been marked as a duplicate of 113885 ***