Bug 127295 - Application crasches after pressing sequently CTRL+S and CTRL+D
Summary: Application crasches after pressing sequently CTRL+S and CTRL+D
Status: RESOLVED DUPLICATE of bug 123315
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-14 11:48 UTC by Ilkka Laitinen
Modified: 2006-06-27 09:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Kate crasch backtrace terminal error (176 bytes, application/octet-stream)
2006-05-21 18:58 UTC, Ilkka Laitinen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilkka Laitinen 2006-05-14 11:48:12 UTC
Version:           2.5.2 (using KDE KDE 3.5.2)
Installed from:    SuSE RPMs
OS:                Linux

The application crashes occasionally after pressing CTRL+D and CTRL-S buttons in random order.

Current configuration:
OS version: Suse 10.0 eval
KDE version: KDE 3.5.2-5 (updated manually)

================ Backtrace ================ 

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1096191680 (LWP 7752)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0x40f05541 in raise () from /lib/tls/libc.so.6
#8  0x40f06dbb in abort () from /lib/tls/libc.so.6
#9  0x40f3b8b5 in __libc_message () from /lib/tls/libc.so.6
#10 0x40f41842 in malloc_printerr () from /lib/tls/libc.so.6
#11 0x40f418da in malloc_consolidate () from /lib/tls/libc.so.6
#12 0x40ffa8c4 in main_arena () from /lib/tls/libc.so.6
#13 0x40ffa8c4 in main_arena () from /lib/tls/libc.so.6
#14 0x0848d348 in ?? ()
#15 0x40ffa8d8 in main_arena () from /lib/tls/libc.so.6
#16 0x00000088 in ?? ()
#17 0x00000018 in ?? ()
#18 0x40ff8ff4 in ?? () from /lib/tls/libc.so.6
#19 0x40ffa8a0 in mp_ () from /lib/tls/libc.so.6
#20 0x00000000 in ?? ()
#21 0xbfdb838c in ?? ()
#22 0x40f42534 in _int_malloc () from /lib/tls/libc.so.6

================ END Backtrace ================
Comment 1 Dominik Haumann 2006-05-14 12:13:30 UTC
I cannot reproduce. Do you have a test file? What highlighting are you using?
Comment 2 Ilkka Laitinen 2006-05-21 18:58:22 UTC
Hi,

I've tried to repeat the bug causing the Kate application crash. 
However, I haven't find any logic which might be the reason, except 
that the crasch occurs when I press CTRL+S after several edits of 
document. I'm using Matlab highlighting.

I started Kate from the terminal. When Kate crashed, there were 
additional information about the crash (see enclosed file).

Regards,
Ilkka




-----Original Message-----
From: Dominik Haumann <dhdev@gmx.de>
To: laiil@netscape.net
Sent: 14 May 2006 10:13:33 -0000
Subject: [Bug 127295] Application crasches after pressing sequently 
CTRL+S and CTRL+D

  ------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.

http://bugs.kde.org/show_bug.cgi?id=127295




------- Additional Comments From dhdev gmx de  2006-05-14 12:13 -------
I cannot reproduce. Do you have a test file? What highlighting are you 
using?


___________________________________________________
Try the New Netscape Mail Today!
Virtually Spam-Free | More Storage | Import Your Contact List
http://mail.netscape.com


Created an attachment (id=16203)
Kate crasch backtrace terminal error
Comment 3 Ilkka Laitinen 2006-05-21 19:07:00 UTC
Hi again,

This is an another error message when I started Kate from the terminal 
and it crashed.

Linux:~> kate
QObject::disconnect: Unexpected null parameter
Linux:~>

Hopefully it helps you.

Regards,
Ilkka



-----Original Message-----
From: Dominik Haumann <dhdev@gmx.de>
To: laiil@netscape.net
Sent: 14 May 2006 10:13:33 -0000
Subject: [Bug 127295] Application crasches after pressing sequently 
CTRL+S and CTRL+D

  ------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.

http://bugs.kde.org/show_bug.cgi?id=127295




------- Additional Comments From dhdev gmx de  2006-05-14 12:13 -------
I cannot reproduce. Do you have a test file? What highlighting are you 
using?


___________________________________________________
Try the New Netscape Mail Today!
Virtually Spam-Free | More Storage | Import Your Contact List
http://mail.netscape.com
Comment 4 Dominik Haumann 2006-06-23 17:56:09 UTC
Do you still have this with newes online updates and KDE 3.5.3? If not, will close it.
Comment 5 Dirk Mueller 2006-06-27 09:00:57 UTC

*** This bug has been marked as a duplicate of 123315 ***