Bug 126725 - suggestions for improvement - useability
Summary: suggestions for improvement - useability
Status: RESOLVED FIXED
Alias: None
Product: ktouch
Classification: Unclassified
Component: general (show other bugs)
Version: 1.5
Platform: unspecified Linux
: NOR wishlist with 60 votes (vote)
Target Milestone: ---
Assignee: Haavard Froeiland
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-04 12:38 UTC by Axel Braun
Modified: 2012-10-26 08:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2006-05-04 12:38:31 UTC
Version:           1.5 (using KDE 3.5.2 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15.8-default

I was looking for a type trainer, so I had a look at ktouch. I found it somewhat difficult to get started with it. maybe you could take the following points in into consideration:

initial start: The first session should be loaded by default.

help manual: 
- screenshots unuseable
- very technical
- something like 'how to get it running without reading the instructions' is missing

What the user wants: Open the program, start a training session.
So if the first session is not loaded by default, the file->open dialog should at least point to the right directory (I assume this is /opt/kde3/share/apps/ktouch/).

Now, in there are some *.ktouch.xml files. But the manual decribes that the lession files end on .ktouch -> this should be synchronized

Next the user may ask: So, what file do I have to select? Proposal: create subdirectories per language.

More, comparing it with commercial products, a brief description of what shall be learned in each section/line could also help to find a decision.
Comment 1 Andrew Ziem 2006-09-01 19:50:45 UTC
There are multiple requests in this issue, so this issue should be broken into multiple issues.  (However, I don't have the permissions to do that.)

To add to the part about starting a training session/lecture:
- The File->Open Lecture opens to the home directory, but it should open to a directory where there's a high probability of finding lectures--e.g., /usr/share/apps/ktouch/.
- The File->Open Lecture and Training->Default Lectures should visually be near each other.  Maybe you could put the Default Lectures under Open Lecture?
Comment 2 petr.bug 2007-03-17 21:44:22 UTC
What can I do move this bug towards completion?

Specially the "The File->Open Lecture opens to the home directory, ..." annoys me.
Comment 3 Rene du R. Sacramento 2007-07-18 07:30:07 UTC
Braun said it very clear and synthetic: "What the user wants: Open the program, start a training session."

"Open lecture.." or "default lectures" and "keyboard layouts" are necessary to do this currently. These three are in separate menus, not very intuitively placed or organized.
 
I thought about an new organization in 4 menus: File (it could also be called "Lecture"), Stats, Settings, Help  (names obviously open to be improved) . I don't see an reason for an "file" menu in ktouch. If it is not prohibited, you can exclude this menu and make 4 menus: Lectures, Stats, Settings, Help  (names obviously open to be improved).  If it is, then call the Lectures menu of File.

* Under the File/Lecture menu go: Open default lecture, Open lecture from a file..., Edit current lecture, Edit lecture from a file... (Instead of "open" the word "load" can be used. I think it is a bit more adequate, but not much difference)
* Under the Stats go: Start new session, Pause session and Lecture Statistics. ("Re-start session" could be an more appropriate name for "Start new session", as far as I perceived how it works, but I can be wrong) 
* The settings menu would remain essentially the same, with only the addition of "Edit color scheme.../Custom color scheme..." inside "Color Schemes"
* The help menu remains the same

In addition to that, while we are at improving usability, the lessions and keyboards layouts should be organized in the menus by language, each one with an country flag attached to it. It will be more and more important as the number of keyboard and lessions shipped with the program grow as I hope it will do. So, to select an lesson for me in this new organization I would (hopefully) go: File > Open Default Lecture > Brazilian Portuguese > QUERTY ABNT2 (auto-generated)/br-nativo (defaut lesson)/br-nativo (combo/speed training)/dvorak-br/whatever , for example. The lecture should automatically load the correct keyboard layout, but leave the possibility to the user change this as it is now. I will fill an new bug about this.



As for one point that others said, the "default lectures" already load all lectures at /opt/kde3/share/apps/ktouch/ every time that you restart the program. So it is not necessary to remap "Open lecture..." to it.


PS: By the way, if you will do the language separation thing in the menu, please separate Brazilian Portuguese/Português do Brasil from "Portuguese" that is Portugal's Portuguese. This for keyboard layouts too, because for some reason we have two quite different standarts, with different number of keys and characters positions in that keys. Then, inside them, we have the variations of key positions. I don't know about the other Portuguese speaker countries, but I assume that they use one of these two general types.  ;)
Comment 4 Jack R. Will 2009-07-19 15:11:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Sebastian Gottfried 2012-10-26 08:04:37 UTC
Version 2.0.0 introduces a complete new home screen to solve the issues here described.

It only presents the courses matching the system's current keyboard layout and the first lesson is already preselected. Gone are all the the menus and dialogs to configure that stuff manually. That way most users will have to only hit "Start Training" to get going.