Bug 126540 - Incorrect re-ordering of multiple sensors on graph
Summary: Incorrect re-ordering of multiple sensors on graph
Status: RESOLVED DUPLICATE of bug 66941
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-30 22:08 UTC by Robert Norton
Modified: 2006-05-26 09:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch -- needs testing (9.94 KB, patch)
2006-05-03 02:11 UTC, Robert Norton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Norton 2006-04-30 22:08:41 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Ubuntu Packages
OS:                Linux

Steps to reproduce:

Open ksysguard, right click physical memory plot, go to sensors tab, move one of them up using 'move up'. Click apply. Notice that none of the traces move position on the graph, although they do change colour at random!

Expected behaviour:

The sensors move and retain their orginal colours.

See also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=350561 .

A minor annoyance to be sure, but annoying enough to make me write this report!
Comment 1 Robert Norton 2006-05-01 01:47:20 UTC
Having had a quick look at the source I see that FancyPlotterSettings.cc re-assigns the sensor 'id' according to the order they are in the list, whilst FancyPlotter.cc tries to match the ids to the ones it has already has when updating the settings, even though they might have changed. 

This could be fixed by having FancyPlotter.cc match the sensors based on their name and then munge the beamColors and sampleBuffer appropriately but this could be quite a tedious operation. An alternative solution would be to remove the Move Up/Down buttons from the settings dialogue....
Comment 2 Robert Norton 2006-05-03 02:11:02 UTC
Created attachment 15883 [details]
Patch -- needs testing

When I said it would be tedious to fix this bug I was not wrong. Anyway here is
the somewhat length patch. Could do with some testing. Now I must go and do
some revision for my finals.
Comment 3 Christopher Martin 2006-05-14 17:38:05 UTC
Any chance of this patch being accepted? I would be a shame to let the patch rot.
Comment 4 Robert Norton 2006-05-14 18:26:19 UTC
Agreed! I'm guessing that the maintainers are snowed under with bug reports since there has been no response from them.

This is my first patch so if there is something I can do to improve the chance of getting it accepted please say!
Comment 5 Robert Norton 2006-05-14 18:28:05 UTC
Oh yes, and I've been using it for the last few weeks without any problems so far.
Comment 6 Greg Martyn 2006-05-26 09:44:36 UTC
I'll have a look at the proposed patch soon. This is a duplicate bug report though.

*** This bug has been marked as a duplicate of 66941 ***