Bug 126285 - reproducible konqueror crash (kjs?) euler.ac-versailles.fr
Summary: reproducible konqueror crash (kjs?) euler.ac-versailles.fr
Status: RESOLVED LATER
Alias: None
Product: konqueror
Classification: Applications
Component: khtml ecma (show other bugs)
Version: 3.5
Platform: Gentoo Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-26 13:11 UTC by Gilles Schintgen
Modified: 2008-05-11 04:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Schintgen 2006-04-26 13:11:34 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Gentoo Packages
OS:                Linux

http://euler.ac-versailles.fr/webMathematica/pi/reperage/graduations2.jsp
I moved the point to the correct position and clicked "Valider". It's reproducible.

Using host libthread_db library "/lib/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1218840912 (LWP 13781)]
[KCrash handler]
#6  0xb6e593a6 in DOM::DocumentImpl::view (this=0x0) at dom_docimpl.h:277
#7  0xb6f4f606 in getLiveConnectExtension (element=@0xbfad0270)
    at kjs_html.cpp:1117
#8  0xb6f4f7d2 in KJS::HTMLElement::tryGet (this=0x8878e98, exec=0xbfad08b0, 
    propertyName=@0xbfad0520) at kjs_html.cpp:1156
#9  0xb6f39ace in KJS::DOMObject::get (this=0x8878e98, exec=0xbfad08b0, 
    p=@0x0) at kjs_binding.cpp:50
#10 0xb6c10df0 in KJS::Reference::getValue (this=0xbfad0510, exec=0xbfad08b0)
    at reference.cpp:143
#11 0xb6bd822f in KJS::FunctionCallNode::evaluate (this=0x895d3d0, 
    exec=0xbfad08b0) at nodes.cpp:835
#12 0xb6bdb181 in KJS::AssignNode::evaluate (this=0x895d3e8, exec=0xbfad08b0)
    at nodes.cpp:1562
#13 0xb6bdcfa2 in KJS::ExprStatementNode::execute (this=0x83dff50, 
    exec=0xbfad08b0) at nodes.cpp:1980
#14 0xb6be314f in KJS::SourceElementsNode::execute (this=0x84748d0, 
    exec=0xbfad08b0) at nodes.cpp:3091
#15 0xb6bdcdd1 in KJS::BlockNode::execute (this=0x895d408, exec=0xbfad08b0)
    at nodes.cpp:1942
#16 0xb6c05c29 in KJS::DeclaredFunctionImp::execute (this=0x0, exec=0x0)
    at function.cpp:588
#17 0xb6c04f2e in KJS::FunctionImp::call (this=0x89505e8, exec=0xbfad0ce0, 
    thisObj=@0x0, args=@0xbfad0a40) at function.cpp:363
#18 0xb6c0a21d in KJS::Object::call (this=0x0, exec=0xbfad0ce0, thisObj=@0x0, 
    args=@0x0) at object.cpp:73
#19 0xb6bd848e in KJS::FunctionCallNode::evaluate (this=0x0, exec=0xbfad0ce0)
    at nodes.cpp:870
#20 0xb6bdcfa2 in KJS::ExprStatementNode::execute (this=0x83f4060, 
    exec=0xbfad0ce0) at nodes.cpp:1980
#21 0xb6be314f in KJS::SourceElementsNode::execute (this=0x88f0620, 
    exec=0xbfad0ce0) at nodes.cpp:3091
#22 0xb6bdcdd1 in KJS::BlockNode::execute (this=0x894bc88, exec=0xbfad0ce0)
    at nodes.cpp:1942
#23 0xb6c05c29 in KJS::DeclaredFunctionImp::execute (this=0x0, exec=0x0)
    at function.cpp:588
#24 0xb6c04f2e in KJS::FunctionImp::call (this=0x8954e18, exec=0x8875fa0, 
    thisObj=@0x0, args=@0xbfad0e90) at function.cpp:363
#25 0xb6c0a21d in KJS::Object::call (this=0x0, exec=0x8875fa0, thisObj=@0x0, 
    args=@0x0) at object.cpp:73
#26 0xb6f92259 in KJS::JSEventListener::handleEvent (this=0x8954e60, 
    evt=@0xbfad0f40) at kjs_events.cpp:95
#27 0xb6f928d8 in KJS::JSLazyEventListener::handleEvent (this=0x8954e60, 
    evt=@0x0) at kjs_events.cpp:151
#28 0xb6e3a950 in DOM::NodeImpl::handleLocalEvents (this=0x894aee8, 
    evt=0x894d570, useCapture=33) at dom_nodeimpl.cpp:616
#29 0xb6e39e53 in DOM::NodeImpl::dispatchGenericEvent (this=0x894aee8, 
    evt=0x894d570) at dom_nodeimpl.cpp:380
#30 0xb6e39aa4 in DOM::NodeImpl::dispatchEvent (this=0x894aee8, 
    evt=0x894d570, exceptioncode=@0x0, tempEvent=true) at dom_nodeimpl.cpp:343
#31 0xb6dd6f8a in KHTMLView::dispatchMouseEvent (this=0x847b008, eventId=4, 
    targetNode=0x894aee8, targetNodeNonShared=0x894d570, cancelable=true, 
    detail=0, _mouse=0xbfad11d0, setUnder=116, mouseEventType=0)
    at khtmlview.cpp:3186
#32 0xb6dcf2b6 in KHTMLView::viewportMouseReleaseEvent (this=0x847b008, 
    _mouse=0xbfad1300) at khtmlview.cpp:1279
#33 0xb6dd0dca in KHTMLView::eventFilter (this=0x847b008, o=0x894e4f0, 
    e=0xbfad18c0) at khtmlview.cpp:1949
#34 0x47af54ce in QObject::activate_filters ()
   from /usr/qt/3/lib/libqt-mt.so.3
#35 0x47af53f6 in QObject::event () from /usr/qt/3/lib/libqt-mt.so.3
#36 0x47b2d1ff in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#37 0x47a9c5fc in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#38 0x47a9bab0 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#39 0xb775454b in KApplication::notify (this=0xbfad20e0, receiver=0x894e4f0, 
    event=0xbfad18c0) at kapplication.cpp:550
#40 0x47a3230c in QETWidget::translateMouseEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#41 0x47a2ff7c in QApplication::x11ProcessEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#42 0x47a4797b in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#43 0x47aae558 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#44 0x47aae408 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#45 0x47a9c831 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#46 0xb733e56c in kdemain (argc=0, argv=0x0) at konq_main.cc:206
#47 0xb761b7d6 in kdeinitmain (argc=0, argv=0x0) at konqueror_dummy.cc:3
#48 0x0804dd0c in launch (argc=2, _name=0x81d9c6c "konqueror", 
    args=0x81d9c7f "\001", cwd=0x0, envc=1, envs=0x81d9c90 "", 
    reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x0)
    at kinit.cpp:639
#49 0x0804f339 in handle_launcher_request (sock=9) at kinit.cpp:1203
#50 0x0804f8a0 in handle_requests (waitForPid=0) at kinit.cpp:1406
#51 0x08050938 in main (argc=2, argv=0xbfad2804, envp=0x0) at kinit.cpp:1850
Comment 1 Tommi Tervo 2006-04-26 13:25:14 UTC
3.5 SVN crashes too. BT is quite similar to Fixed #112653
Comment 2 Maksim Orlovich 2008-01-24 21:48:00 UTC
SVN commit 765886 by orlovich:

Don't improperly attach when not needed
(fixes crash on #126285, which is different from the one reported.
 It's stable in 4.x after this, but I still need to analyze the 3.5.x
 one to be confident, since it's a weird one)
CCBUG: 126285


 M  +17 -17    html_objectimpl.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=765886
Comment 3 Maksim Orlovich 2008-01-24 21:49:38 UTC
SVN commit 765894 by orlovich:

Don't improperly attach when not needed
(fixes crash on #126285, which is different from the one reported.
 It's stable in 4.x after this, but I still need to analyze the 3.5.x
 one to be confident, since it's a weird one)
CCBUG: 126285



 M  +17 -17    html_objectimpl.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=765894
Comment 4 A. Spehr 2008-01-24 22:41:47 UTC
fwiw, this crashes in 3.5.8
Comment 5 James Spahlinger 2008-04-20 02:18:28 UTC
works for me in 4.0.3 - no crash

when I finish compiling 3.5.9 I'll try there.

Using Gentoo Linux ~x86 (testing in gentoo lingo). KDE and the majority of packages compiled using gcc 4.3.0. 
Comment 6 FiNeX 2008-05-05 11:05:58 UTC
3.5.9: Crash :-(
4.1 (trunk r802881): Doesn't crash :-)

Should we set this as "LATER" or should we let it open?
Comment 7 James Spahlinger 2008-05-11 04:11:58 UTC
Closed as later.