Bug 126261 - (jcxz) vex x86->IR: unhandled instruction bytes: 0x67 0xE3 0x3 0x83
Summary: (jcxz) vex x86->IR: unhandled instruction bytes: 0x67 0xE3 0x3 0x83
Status: RESOLVED DUPLICATE of bug 137095
Alias: None
Product: valgrind
Classification: Developer tools
Component: vex (show other bugs)
Version: 3.2 SVN
Platform: Compiled Sources Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-25 23:43 UTC by Thomas Kühne
Modified: 2006-11-10 01:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kühne 2006-04-25 23:43:45 UTC
12:   66 b9 00 00             mov    cx,0x0
  16:   67 e3 03                addr16 jcxz 1c <_Dmain+0x1c>
  19:   83 c0 01                add    eax,0x1

(http://dstress.kuehne.cn/run/a/asm_jczx_01_A.d)
Comment 1 Julian Seward 2006-05-03 16:47:27 UTC
>            Summary: (jcxz) vex x86->IR: unhandled instruction bytes: 0x67

0x67 is an address-size override, which makes it seem pretty dubious in 
32-bit user-mode.  Unless you're doing something strange like Wine does.
Comment 2 Ruud Schramp (via spam catcher) 2006-11-09 22:13:38 UTC
Patch available: check 137095 
Comment 3 Tom Hughes 2006-11-10 01:08:57 UTC

*** This bug has been marked as a duplicate of 137095 ***