Bug 126240 - vex x86->IR: unhandled instruction bytes: 0xC8 0x0 0x8 0x1E
Summary: vex x86->IR: unhandled instruction bytes: 0xC8 0x0 0x8 0x1E
Status: RESOLVED DUPLICATE of bug 88116
Alias: None
Product: valgrind
Classification: Developer tools
Component: vex (show other bugs)
Version: 3.2 SVN
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-25 22:34 UTC by Thomas Kühne
Modified: 2010-11-11 20:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kühne 2006-04-25 22:34:12 UTC
1:   8b ec                   mov    ebp,esp
   3:   83 ec 04                sub    esp,0x4
   6:   c7 45 fc 01 00 00 00    mov    DWORD PTR [ebp-4],0x1
   d:   8b 45 fc                mov    eax,DWORD PTR [ebp-4]
  10:   c8 00 08 1e             enter  0x800,0x1e
  14:   c9                      leave  
  15:   40                      inc    eax
  16:   89 45 fc                mov    DWORD PTR [ebp-4],eax
  19:   83 7d fc 02             cmp    DWORD PTR [ebp-4],0x2
  1d:   74 0a                   je     29 <_Dmain+0x29>
  1f:   b8 13 00 00 00          mov    eax,0x13
  24:   e8 fc ff ff ff          call   25 <_Dmain+0x25>
  29:   31 c0                   xor    eax,eax
  2b:   c9                      leave  
  2c:   c3                      ret    

(http://dstress.kuehne.cn/run/a/asm_leave_01.d)
Comment 1 Vince Weaver 2010-11-11 20:11:37 UTC

*** This bug has been marked as a duplicate of bug 88116 ***