Bug 126238 - vex x86->IR: unhandled instruction bytes: 0x67 0xE3 0x3 0x83
Summary: vex x86->IR: unhandled instruction bytes: 0x67 0xE3 0x3 0x83
Status: RESOLVED DUPLICATE of bug 137095
Alias: None
Product: valgrind
Classification: Developer tools
Component: vex (show other bugs)
Version: 3.2 SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-25 22:32 UTC by Thomas Kühne
Modified: 2006-11-10 01:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kühne 2006-04-25 22:32:55 UTC
0:   55                      push   %ebp
   1:   8b ec                   mov    %esp,%ebp
   3:   83 ec 04                sub    $0x4,%esp
   6:   c7 45 fc 00 00 00 00    movl   $0x0,0xfffffffc(%ebp)
   d:   b8 00 00 00 00          mov    $0x0,%eax
  12:   66 b9 02 00             mov    $0x2,%cx
  16:   67 e3 03                jcxz   1c <_Dmain+0x1c>
  19:   83 c0 01                add    $0x1,%eax
  1c:   89 45 fc                mov    %eax,0xfffffffc(%ebp)
  1f:   83 7d fc 01             cmpl   $0x1,0xfffffffc(%ebp)
  23:   74 0a                   je     2f <_Dmain+0x2f>
  25:   b8 13 00 00 00          mov    $0x13,%eax
  2a:   e8 fc ff ff ff          call   2b <_Dmain+0x2b>
  2f:   31 c0                   xor    %eax,%eax
  31:   c9                      leave  
  32:   c3                      ret


(http://dstress.kuehne.cn/run/a/asm_jczx_01_B.d)
Comment 1 Ruud Schramp (via spam catcher) 2006-11-09 22:12:57 UTC
patch available: check bug 137095 
Comment 2 Tom Hughes 2006-11-10 01:09:31 UTC

*** This bug has been marked as a duplicate of 137095 ***