Bug 126103 - kmail become slow when using search line filter with 10000+ mails
Summary: kmail become slow when using search line filter with 10000+ mails
Status: RESOLVED DUPLICATE of bug 138912
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 126683 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-23 13:28 UTC by LuRan
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LuRan 2006-04-23 13:28:04 UTC
Version:           svn snapshot from 3.5 branch (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.1.0 
OS:                Linux

I have a mailbox with 10000+ mails, when I use the search line to search for some
keywords, kmail become very slow, either scrolling the result or rightclick on a
mail. Even switching to another window and then switch back will make it hang for
about 2s on my athlon-xp 2500+.
Comment 1 tropikhajma 2006-11-29 20:39:55 UTC
confirm this one at Mandriva Cooker, KDE 3.5.5, KMail 1.9.5
Not only is the search a bit slow, even worse - it seems, that the search is performed at every UI refresh, i.e.:
0) launch top
1) perform a quick search on a folder with 40k+ messages and wait for CPU to get back to 0
2) minimize and maximize KMail (or move the scrollbar or whatever)
3) watch it eating your CPU again

the only solution is to use the full search
Comment 2 LuRan 2006-12-17 13:05:12 UTC
I spent some time to debug the problem, and I found that the bad guy is the alternative background of KListView, after comment out the code in klistview.cpp, the slowness went away.
Comment 3 Thomas McGuire 2007-02-21 17:39:09 UTC
*** Bug 126683 has been marked as a duplicate of this bug. ***
Comment 4 FACORAT Fabrice 2007-02-21 17:53:31 UTC
could something be done about this ?
Comment 5 Pavel Volkovitskiy 2007-02-22 10:02:28 UTC
related KListView bug
http://bugs.kde.org/show_bug.cgi?id=138912
Comment 6 Bram Schoenmakers 2007-02-25 21:39:19 UTC
Marking as a dupe of bug 138912, most probably it describes the general cause for this problem.

*** This bug has been marked as a duplicate of 138912 ***