Bug 125186 - Kopete reports error code 911
Summary: Kopete reports error code 911
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: MSN Plugin (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 129119 137825 139400 152014 158370 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-08 19:25 UTC by 81joe81
Modified: 2008-11-15 06:09 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 81joe81 2006-04-08 19:25:54 UTC
Version:           0.12-SVN (using KDE KDE 3.5.2)
Installed from:    Ubuntu Packages
OS:                Linux

In a window, kopete has reported an error in the MSN plugin with code 911
This is the output on the command line, where $myMSNfriend and $myMSNaccount are fake variables I have inserted to hide email addresses:

kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] RNG 1344985576 207.46.26.155:1863 CKI 250247126.1143845 $myMSNfriend
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: ANS 0 $myMSNaccount 250247126.11
43845 1344985576
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] 911 0
kopete (msn): [virtual void MSNSwitchBoardSocket::handleError(uint, uint)]
kopete (msn): [virtual void MSNSocket::handleError(uint, uint)]
kopete (msn): [void MSNAccount::slotErrorMessageReceived(int, const QString&)] Codice d'errore MSN non gestito 911
Invia una dettagliata segnalazione di bug, se possibile con l'ultimo output di debug della console.
kopete (msn): WARNING: [void MSNSocket::slotSocketError(int)] Error: 17 (connessione chiusa dall'host remoto)
kopete (msn): [virtual MSNSwitchBoardSocket::~MSNSwitchBoardSocket()]
libkopete: [void Kopete::ChatSessionManager::removeSession(Kopete::ChatSession*)]
Comment 1 Philip Rodrigues 2006-04-08 21:02:38 UTC
What were you doing in kopete when it reported this error? Is it reproducible?
Comment 2 81joe81 2006-04-08 23:30:20 UTC
I was doing nothing special...
I think my friend tried to do something: tomorrow I will ask her something about it

I post lines about MSN plugin before that error:

Sending command: MSG 318 U 53
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: PNG
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] QNG 40
kopete (msn): [virtual void MSNNotifySocket::parseCommand(const QString&, uint, const QString&)] timerTimeout=40sec
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: MSG 319 U 53
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: PNG
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] QNG 47
kopete (msn): [virtual void MSNNotifySocket::parseCommand(const QString&, uint, const QString&)] timerTimeout=47sec
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] NLN NLN $myMSNfriend (*)Stellina 1342554156 %3Cmsnobj%20Creator%3D%22$myMSNfriend%22%20Size%3D%2218349%22%20Type%3D%223%22%20Location%3D%22TFRD.dat%22%20Friendly%3D%22AAA%3D%22%20SHA1D%3D%22JbybTEQih%2FY2o8z%2FMEUPFDs1YVk%3D%22%20SHA1C%3D%22f5mUIngYAJYC91Pgj2Nh%2FBVsDXk%3D%22%2F%3E
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: MSG 320 U 53
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: PNG
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] QNG 48
kopete (msn): [virtual void MSNNotifySocket::parseCommand(const QString&, uint, const QString&)] timerTimeout=48sec
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] RNG 1344985576 207.46.26.155:1863 CKI 250247126.1143845 $myMSNfriend (*)Stellina
kopete (msn - raw protocol): [virtual void MSNSocket::slotReadyWrite()] Sending command: ANS 0 $myMSNaccount 250247126.1143845 1344985576
kopete (msn - raw protocol): [void MSNSocket::slotDataReceived()] 911 0
kopete (msn): [virtual void MSNSwitchBoardSocket::handleError(uint, uint)] 
kopete (msn): [virtual void MSNSocket::handleError(uint, uint)] 
kopete (msn): [void MSNAccount::slotErrorMessageReceived(int, const QString&)] Codice d'errore MSN non gestito 911
kopete (msn): WARNING: [void MSNSocket::slotSocketError(int)] Error: 17 (connessione chiusa dall'host remoto)
kopete (msn): [virtual MSNSwitchBoardSocket::~MSNSwitchBoardSocket()] 
Comment 3 CoolCubix 2006-06-12 23:39:21 UTC
I has the same bug recently. I (really) don't know if this could help : I saw the message box "911 error" when I came back to my computer, and i saw in the background a MSN window which I left open before. IIRC, the window used to be a multi-user chat for MSN, but came back single-user chat. I saw in this window a bunch of animated-gif's emoticons flashing (at least fifty). Until I send the SIGSTOP signal to kopete, it takes 100% CPU. Closing the chat window don't stop this ; however I saw in my contact list some new messages pending (the "letter" icon flashing with contact's personal picture). The two contacts who sent me some messages used funny characters several times in their nick:  ·₪♥๑ҳҲ   and also an URL. 

Qt: 3.3.6
KDE: 3.5.3
Kopete: 0.11.2
Debian Etch (testing)

Hope it could help :)
Comment 4 Alexandre Oliveira 2006-10-21 04:58:36 UTC
*** Bug 129119 has been marked as a duplicate of this bug. ***
Comment 5 Bram Schoenmakers 2006-11-24 20:10:14 UTC
*** Bug 137825 has been marked as a duplicate of this bug. ***
Comment 6 Michaël Larouche 2006-12-12 16:36:39 UTC
Fixed in SVN r612769.
Comment 7 Bram Schoenmakers 2006-12-31 02:38:11 UTC
*** Bug 139400 has been marked as a duplicate of this bug. ***
Comment 8 Pino Toscano 2007-11-09 12:38:55 UTC
*** Bug 152014 has been marked as a duplicate of this bug. ***
Comment 9 Theresa 2008-02-25 11:43:01 UTC
i'm getting this error on a daily basis since using the new Kopete on KDE 4.0.1

On KDE 3.5.8 I don't receive such an error.
Comment 10 Philip Rodrigues 2008-07-06 12:54:33 UTC
*** Bug 158370 has been marked as a duplicate of this bug. ***
Comment 11 Philip Rodrigues 2008-07-06 13:00:51 UTC
I can confirm this in svn trunk r828586. 
Comment 12 Dennis Nienhüser 2008-07-06 13:05:32 UTC
It was fixed in branches/3.5, but not ported to trunk yet. I have a patch locally and will commit it after string freeze.
Comment 13 Kristjan Ugrin 2008-07-15 22:07:40 UTC
Steps to reproduce:
1. set your msn account(s) to automatically fetch avatars
2. shutdown kopete
3. delete contactlist xml and contacts avatars folder
4. start kopete

when it starts fetching avatars, this error message should appear
Comment 14 Matt Rogers 2008-11-15 06:09:10 UTC
We've completely replaced the current MSN implementation with a new MSN implementation which  If you continue to experience this bug after testing the new implementation (which can be gotten from our subversion repository or with the KDE 4.2 Beta 1 release), PLEASE, open a new bug rather than reopening this bug. Thank you for your time and efforting in helping us find and fix problems in Kopete.