Bug 125123 - Comment function dont work correct with static line break
Summary: Comment function dont work correct with static line break
Status: RESOLVED DUPLICATE of bug 105373
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-07 16:40 UTC by Ronaldo Reis Júnior
Modified: 2007-12-10 19:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronaldo Reis Júnior 2006-04-07 16:40:41 UTC
Version:           1.9 (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I use kile with static word wrap, the lines must be break at column 80. It OK.

But, when I try to comment out a region, some text are not commented because the line break.

Look this example:

The BioMa (\textbf{Bio}diveristy data \textbf{Ma}nager) project started in
2004 and now, three beta versions for tests are available. However, the project
is poor in scalability and flexibility, because all layers (View, Controler and
Model) is implemented in one layer, in a mixed mode. In this way, BioMa is
not able to be easy implemented in others systems, like a palmtop or a desktop
environment. To fix this limitation, we make a project to remodel BioMa in
a three layers system. The basic BioMa's code may be totally independent of
any interfaces implementation, making possible the development of any interface
in any method (PHP, GTK, etc). Thus the main goal of this workshop is to debate
about the technicalities this new model in a sustainability way.

When I select and comment this region, look the result:

% The BioMa (\textbf{Bio}diveristy data \textbf{Ma}nager) project started in
% 2004 and now, three beta versions for tests are available. However, the
project % is poor in scalability and flexibility, because all layers (View,
Controler and % Model) is implemented in one layer, in a mixed mode. In this
way, BioMa is
% not able to be easy implemented in others systems, like a palmtop or a desktop
% environment. To fix this limitation, we make a project to remodel BioMa in
% a three layers system. The basic BioMa's code may be totally independent of
% any interfaces implementation, making possible the development of any
interface % in any method (PHP, GTK, etc). Thus the main goal of this workshop
is to debate % about the technicalities this new model in a sustainability way.

Thanks
Ronaldo
Comment 1 Ronaldo Reis Júnior 2006-08-29 13:23:08 UTC
Hi,

This problem continue. Now I know that is not a kile problem, but a kate (kwrite) problem.

I think that this is a serious bug, mainly for kile/latex users, because on comment of large piece of text, the comment dont work, unless if you are using dinamic line break.

I think that commented line must be not static, but dinamic broken. Even if all text is static broken.

I know that my english is bad, do you understand the problem?

Thanks 
Ronaldo
Comment 2 Ronaldo Reis Júnior 2006-11-08 17:57:19 UTC
Hi,

this problem continue and it is serious problem, mainly with latex users.

I cant mark a block of text to comment out. If the line break is static, the comment is wrong.

This is not a UNCONFIRMED problem.

Thanks
Ronaldo
Comment 3 Thomas Friedrichsmeier 2007-12-10 19:56:55 UTC

*** This bug has been marked as a duplicate of 105373 ***