Bug 125072 - crash after closing konqueror window [backtrace]
Summary: crash after closing konqueror window [backtrace]
Status: RESOLVED DUPLICATE of bug 119512
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-06 22:25 UTC by Dik Takken
Modified: 2006-04-06 22:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dik Takken 2006-04-06 22:25:20 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Gentoo Packages
OS:                Linux

I just got this backtrace after konqueror crashed on closing:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 32178)]
[KCrash handler]
#6  0x00000399 in ?? ()
#7  0xb68f0b0e in QDict<khtml::CachedObject>::deleteItem(void*) (
    this=0x8f3e370, d=0x8f3dfc8) at qdict.h:97
#8  0xb72372ac in QGDict::clear() () from /usr/qt/3/lib/libqt-mt.so.3
#9  0xb68f095f in QDict<khtml::CachedObject>::clear() (this=0x8f3e370)
    at qdict.h:75
#10 0xb68f041d in ~QDict (this=0x82e5770) at qdict.h:57
#11 0xb68ea59a in khtml::Cache::clear() () at loader.cpp:1288
#12 0xb67bff45 in ~KHTMLFactory (this=0x839df68) at khtml_factory.cpp:98
#13 0xb67c0148 in KHTMLFactory::deref() () at khtml_factory.cpp:139
#14 0xb67bfe77 in ~KHTMLFactory (this=0x83c9690) at khtml_factory.cpp:103
#15 0xb75e4b25 in ~KLibrary (this=0x82d6f50) at klibloader.cpp:131
#16 0xb75e674e in KLibLoader::close_pending(KLibWrapPrivate*) (this=0x83c1098, 
    wrap=0x82d6590) at klibloader.cpp:516
#17 0xb75e5c1d in ~KLibLoader (this=0x83c1098) at klibloader.cpp:328
#18 0xb75e55d3 in KLibLoader::cleanUp() () at klibloader.cpp:298
#19 0xb755fa4b in ~KApplication (this=0xbfed86a0) at kapplication.cpp:1610
#20 0xb7facef9 in ~KonquerorApplication (this=0x8f3e370) at konq_main.cc:58
#21 0xb7f4028e in kdemain (argc=150201200, argv=0x8f3e370) at konq_main.cc:221
#22 0x080486eb in main (argc=150201200, argv=0x8f3e370) at konqueror.la.cc:2
Comment 1 Tommi Tervo 2006-04-06 22:32:31 UTC

*** This bug has been marked as a duplicate of 119512 ***