Bug 124663 - "Kommander Quick Start Dialog" produces invalid xhtml 1.0 strict with javascript code
Summary: "Kommander Quick Start Dialog" produces invalid xhtml 1.0 strict with javascr...
Status: RESOLVED FIXED
Alias: None
Product: quanta
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: András Manţia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-31 18:49 UTC by Fathi Boudra
Modified: 2006-05-20 17:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
the trivial file used (475 bytes, text/xml)
2006-03-31 18:50 UTC, Fathi Boudra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fathi Boudra 2006-03-31 18:49:12 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

This is a forwarded bug :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=339367

If I generate an XHTML-Strict file with "Quick Start" of Quanta, and I
include a "JavaScript area". A validation of this file with the program "validate" gives the error message:
there is no attribute "language"

-------------------------------------------------------------

I tried to reproduce, so i generate a test.xml as explained and used the W3C Markup Validation Service : http://validator.w3.org

Giving me this result:
This page is not Valid XHTML 1.0 Strict!
Below are the results of checking this document for XML well-formedness and validity.
Error Line 9 column 19: there is no attribute "language".
<script language="javascript" type="text/javascript">
You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead). 
This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information. 
How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute.

cheers,

Fathi
Comment 1 Fathi Boudra 2006-03-31 18:50:20 UTC
Created attachment 15399 [details]
the trivial file used
Comment 2 András Manţia 2006-05-20 17:34:24 UTC
Fixed in 3.5.3.