Bug 124495 - Free/Busy information not renerated for recurring events with end date after fb-period
Summary: Free/Busy information not renerated for recurring events with end date after ...
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-29 15:03 UTC by Philipp Hahn
Modified: 2007-10-01 19:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Source Calendar (941 bytes, text/calendar)
2006-03-29 15:07 UTC, Philipp Hahn
Details
Generated free/busy information (629 bytes, text/directory)
2006-03-29 15:10 UTC, Philipp Hahn
Details
Small test program to show bug (1.51 KB, text/plain)
2006-03-30 08:20 UTC, Philipp Hahn
Details
Fix RecurrenceRule::endDt() (1.34 KB, patch)
2006-03-30 14:40 UTC, Philipp Hahn
Details
Fix CalendarLocal::rawEvents (4.79 KB, patch)
2006-03-30 14:43 UTC, Philipp Hahn
Details
updated patch for CalendarLocal::rawEvents (4.76 KB, patch)
2007-10-01 14:01 UTC, Tim Weber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn 2006-03-29 15:03:38 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

The published free/busy-information does not include all events, especially those recurring events which expire after the last day included in the free/busy-information are missing.

1. check the "publish 60 days of free/busy information" setting
2. create a first weekly recurring one hour event with end-date < 60 days
3. create a second weekly recurring one hour event with end-date > 60 days
4. publish free/busy information
   event one is included
   event two is missing
Comment 1 Philipp Hahn 2006-03-29 15:07:14 UTC
Created attachment 15349 [details]
Source Calendar

A sample calendar with three recurring events which recurr until dates spaced
one month after each other.
Comment 2 Philipp Hahn 2006-03-29 15:10:13 UTC
Created attachment 15350 [details]
Generated free/busy information

Generated free/busy information from calendar with three recurring events which
recurr until dates spaces one month after each other.
Entries for Event C 'FREEBUSY:2006....T130000Z/2006....T140000Z' are missing.
Comment 3 Philipp Hahn 2006-03-30 08:20:10 UTC
Created attachment 15369 [details]
Small test program to show bug

This small program creates a calendar which shows the bug. Put it in
kdepim/libkcal/tests, add it to Makefile.am the same as the "readandwrite"
test, compile and run it.
The generated free/busy-information only includes event 'A' but not 'B'.
Comment 4 Philipp Hahn 2006-03-30 08:23:01 UTC
One more comment: The recurring event must start before the FB-interval and must run until after the FB-interval to show the bug. If the event first starts inside the FB-interval, is shows correctly.
Comment 5 Philipp Hahn 2006-03-30 14:40:47 UTC
Created attachment 15374 [details]
Fix RecurrenceRule::endDt()

* Fix assignment of boolen value to pointer to boolean
* Actually also asign true some times
Comment 6 Philipp Hahn 2006-03-30 14:43:28 UTC
Created attachment 15375 [details]
Fix CalendarLocal::rawEvents

Rewrite the whole function from if^5-nesting to something more human
understandable.
This fixes the generation of my Free/Busy-Information but needs to be checked
for other users.
Comment 7 Reinhold Kainhofer 2006-11-02 19:16:01 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 8 Tim Weber 2007-10-01 14:01:13 UTC
Created attachment 21726 [details]
updated patch for CalendarLocal::rawEvents

I can confirm that this bug still exists in 3.5.7. Philipp's patches from #5
and #6 seem to fix it. The changes from r614014 of December 16 2006 (see
http://websvn.kde.org/?view=rev&revision=614014) require one line in the second
patch to be changed to make it apply cleanly. I've attached the corrected
patch.

Note that this bug's impact is more than just cosmetic: It breaks the export of
free/busy information for many recurring events and makes the KOrganizer user
look unprofessional. Since the bug can be fixed by applying these two small
patches, this should definitely be something to be fixed in KDE 4.0.
Comment 9 Allen Winter 2007-10-01 19:05:01 UTC
SVN commit 719675 by winterz:

Fix bug "Free/Busy information not renerated for recurring events with end date after fb-period"

Thanks to the patches and test progam from Philipp 
and the extra testing by Tim.

BUGS: 124495


 M  +61 -48    calendarlocal.cpp  
 M  +10 -16    recurrencerule.cpp  
 M  +7 -2      tests/Makefile.am  
 A             tests/fbrecurring.cpp   [License: no copyright]


WebSVN link: http://websvn.kde.org/?view=rev&revision=719675