Bug 124321 - kmail crashes while searching text in messages
Summary: kmail crashes while searching text in messages
Status: RESOLVED DUPLICATE of bug 113885
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-26 19:48 UTC by kavol
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kavol 2006-03-26 19:48:45 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.4.5 (Gentoo 3.4.5, ssp-3.4.5-1.0, pie-8.7.9) 
OS:                Linux

Hello,

I was trying to find something within my archive and kmail crashes on this ... Since I use Gentoo, I recompiled kmail with USE="debug" and here is the backtrace. The exact way to repeat the crash is easy for me, I just start kmail, select Tools => Find messages => Search in all local folders => <message> contains "ticketpro" => Search

I see that there are some reports of kmail crashing while searching, but I do not think that this is duplicate ... I think this has to do something with my environment.


backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
[... repeating message ...]
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 46912612182240 (LWP 1926)]
[New Thread 1107310944 (LWP 1934)]
[New Thread 1098918240 (LWP 1933)]
[New Thread 1090525536 (LWP 1932)]
[New Thread 1082132832 (LWP 1931)]
0x00002aaab17ba295 in nanosleep () from /lib/tls/libc.so.6
#0  0x00002aaab17ba295 in nanosleep () from /lib/tls/libc.so.6
#1  0x00002aaab17ba100 in sleep () from /lib/tls/libc.so.6
#2  0x00002aaaae894bea in KCrash::startDrKonqi ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#3  0x00002aaaae8b709e in KCrash::defaultCrashHandler ()
   from /usr/kde/3.5/lib64/libkdecore.so.4
#4  0x00002aaab175c890 in killpg () from /lib/tls/libc.so.6
#5  0x0000000000000000 in ?? ()


console output:
[... lines before search omitted ...]
kmail: capabilities:(imap4,imap4rev1,starttls,namespace,idle,mailbox-referrals,scan,sort,thread=references,thread=orderedsubject,multiappend)
kmail: RuleWidgetHandlerManager::createWidgets: regExpLineEdit already exists in valueStack
kmail: RuleWidgetHandlerManager::createWidgets: textRuleValueHider already exists in valueStack
kmail: RuleWidgetHandlerManager::createWidgets: regExpLineEdit already exists in valueStack
kmail: RuleWidgetHandlerManager::createWidgets: textRuleValueHider already exists in valueStack
kmail: Creating folder /home/kavol/.kde/share/apps/kmail/search/Poslední hledání
kmail: KMSearchPattern::purify(): removing "" <contains> ""
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] akce found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] comp found 0
kmail: Koncepty: serNum 1936545793 matches?false
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Koncepty found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] hromadne found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Došlá pošta found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Došlá pošta found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] jobs found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] lidé found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] misc found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] misc found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] music found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] OE5-_xchat found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Odchozí found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-COPYSELF found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-COPYSELF found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-New Messages found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-COPYSELF found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-Petra found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-COPYSELF found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] PMail-Sarka found 0
kmail: WARNING: QuotedPrintableDecoder: \xffffffe9 illegal character in input stream! Ignoring.
kmail: WARNING: QuotedPrintableDecoder: \xffffffe9 illegal character in input stream! Ignoring.
kmail: WARNING: QuotedPrintableDecoder: \xffffffe9 illegal character in input stream! Ignoring.
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Quaxatixl found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] rodina found 0
kmail: Odeslaná pošta: serNum 1936569413 matches?false
kmail: Odeslaná pošta: serNum 1936569414 matches?false
[... repeating message with increasing serNum ...]
kmail: Odeslaná pošta: serNum 1936569507 matches?false
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Odeslaná pošta found 0
kmail: Odeslaná pošta: serNum 1936569532 matches?false
kmail: Odeslaná pošta: serNum 1936569533 matches?false
kmail: Odeslaná pošta: serNum 1936569534 matches?false
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] Odeslaná pošta found 0
kmail: [void KMSearch::slotSearchFolderResult(KMFolder*, QValueList<Q_UINT32>, const KMSearchPattern*, bool)] tmp found 0
kmail: kmsearchpattern.cpp:325: virtual bool KMSearchRuleString::matches(const KMMessage*) const: Předpoklad `msg' nesplněn.
*** KMail got signal 6 (Crashing)
KCrash: Application 'kmail' crashing...
Comment 1 kavol 2006-04-02 19:24:58 UTC
I am unable to reproduce this under 3.5.2 (kmail 1.9.1) so I consider it fixed ...
Comment 2 kavol 2006-04-26 09:36:15 UTC
even the new version crashes again on another query, so reopening ...

the error message is the same:

kmail: kmsearchpattern.cpp:325: virtual bool KMSearchRuleString::matches(const KMMessage*) const: Předpoklad `msg' nesplněn.
*** KMail got signal 6 (Crashing)
Comment 3 Will Stephenson 2007-03-23 18:59:57 UTC

*** This bug has been marked as a duplicate of 113885 ***