Bug 124216 - Kmail runs out of memory when importing large Outlook Express mailboxes
Summary: Kmail runs out of memory when importing large Outlook Express mailboxes
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-25 05:51 UTC by Mark Wagner
Modified: 2014-01-05 17:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
An Outlook Express mailbox containing 2351 mailing-list emails (966.12 KB, application/octet-stream)
2006-04-28 03:01 UTC, Mark Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Wagner 2006-03-25 05:51:56 UTC
Version:            (using KDE KDE 3.4.3)
Installed from:    Gentoo Packages
Compiler:          GCC 3.3.6 
OS:                Linux

When importing an Outlook Express mailbox with approximately 22,000 messages in it, Kmail used up all available memory on my system (approximately 750 MB) after importing 16,295 messages and was killed by the OS.
Comment 1 Philip Rodrigues 2006-03-25 15:45:30 UTC
Do you have a different mailbox to test with? (ie, to see if it's a problem with large outlook mailboxes in general, or just the one you tried)
Comment 2 Mark Wagner 2006-03-26 00:39:40 UTC
I've only got one mailbox large enough.  It successfully imported the second and third largest mailboxes I've got, at 5700 and 3600 messages respectively.
Comment 3 Philip Rodrigues 2006-03-27 18:09:37 UTC
Can you artificially create a large outlook mailbox (say, by copy/pasting a message lots of times in outlook), and try importing that to kmail?
Comment 4 Mark Wagner 2006-04-03 03:34:06 UTC
I haven't been able to reproduce this behavior exactly with any other mailbox, but by adjusting the amount of free memory on my system, I'm able to get any mailbox with 2500+ messages to cause the system to run out of memory and kill *something* to free up memory -- it's just never been kmail that's been killed.
Comment 5 Ismail Onur Filiz 2006-04-10 02:09:35 UTC
Could you attach a large (and possibly one small) outlook mailbox, so that I can try importing?
Comment 6 Danny Kukawka 2006-04-10 15:08:20 UTC
Is Kmail or KmailCVT using all your memory? 

We had such problems already in the past and this was fixed (see http://lists.kde.org/?l=kde-pim&m=111139960430968&w=2).

I take a look at this and try to reproduce.
Comment 7 Mark Wagner 2006-04-13 05:10:37 UTC
According to "top", Kmail's what's using the memory.  KmailCVT stays under 15MB the whole time.

As for providing a large mailbox, I'd like to, but the bug reporter's got a limit of 1MB on attachments, and I can't compress any of the large mailboxes I've got down below about 1.5MB.
Comment 8 Ismail Onur Filiz 2006-04-22 07:46:35 UTC
1MB is fine too. For the mailbox, you don't need to send your private email, just create a mailbox with some bogus emails in it, and duplicate them a few times so that the box is large enough. I'm asking this because I don't have Outlook:)
Comment 9 Mark Wagner 2006-04-28 03:01:10 UTC
Created attachment 15808 [details]
An Outlook Express mailbox containing 2351 mailing-list emails

An Outlook Express mailbox containing 2351 mailing-list emails.  On my system,
importing it into Kmail causes Kmail to use an additional 44MB of memory.
Comment 10 Ole Langbehn 2007-07-24 09:42:19 UTC
I'm also running into the problem of too much memory usage when fetching 40000 mails from pop3. after about 28.000 mails, my system is thrashing and kmail is using all of the memory it can get (1,5G mem, 3G swap).
Comment 11 Sergio Martins 2013-06-28 17:28:17 UTC
Please retest on a recent version.
Comment 12 Mark Wagner 2013-07-13 10:03:52 UTC
Retesting will need to wait for Bug 322303 to be resolved.
Comment 13 Mark Wagner 2014-01-05 11:01:52 UTC
Appears to be fixed.  I just successfully imported a large (22,000 message) mailbox with no appreciable change in memory usage by either Kmail or KmailCVT.