Bug 124141 - option for tabulary window managment
Summary: option for tabulary window managment
Status: RESOLVED DUPLICATE of bug 59338
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-23 16:36 UTC by Victor-Philipp Busch
Modified: 2006-03-27 14:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor-Philipp Busch 2006-03-23 16:36:53 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages

Ok, I have a crazy wish:

I want to see an option for tabulary window managment like ION. Why? Ok, let me explain it:

My old grandma has an old PC with KDE on it. Now she is confused about the windows and if they overlapped she can't work with it (she is too confused then :( ). Perhaps is my wish interesting for handicapped persons too.

If kwin
1. prohibit to overlap of one ore more windows
and 
2. if two windows adjoin, you can enlarge one and the other would be reduced.

The advantages are:
1. Windows can't confused old people, then they can see them all ;)
2. With an additional Zoom-function windows can be maximized and the other windows would be minimized but not overlapped
3. Windows, wich requires an action, can easily give an graphical info (for example with red borders).

PS: Why not ION? 1. ION ist NOT KDE ;) and 2. ION is only for programmers configurable :(
Comment 1 Philip Rodrigues 2006-03-24 11:35:40 UTC
FYI, You can run any window manager you like under KDE by setting the KDEWM environment variable
Comment 2 Lubos Lunak 2006-03-27 14:57:02 UTC

*** This bug has been marked as a duplicate of 59338 ***