Bug 123530 - Unable to retrieve file error message
Summary: Unable to retrieve file error message
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: 0.8.1
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-13 01:35 UTC by Michael R. Lindsay
Modified: 2022-01-23 09:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael R. Lindsay 2006-03-13 01:35:19 UTC
Version:           0.8.1 (using KDE KDE 3.4.2)
Installed from:    SuSE RPMs
Compiler:          GNU C compiler gcc version 4.0.2_20050901-3
OS:                Linux

Digikam fails downloading all files from Kodak Z7590 camera with "Failed to retreive file" error message. Camera must then be power cycled before you try again. Thumdnails and file names are being correctly displayed in digikam. The program gphoto2 is able to download the files. The application f-spot running under GNOME also is failing to download files. Problem may be gphoto2 related but as far as I can tell I'm running the latest version of gphoto2 and libgphoto2 as shown below.

I can also sucessfully access the files via Konqueror or gwenview. 

This problem may have been resolved in earlier version and resurfaced with this latest version.

camera://Kodak Z7590@[usb:004,019]/store_00010001/DCIM/100Z7590

 Based on similar errors with older versions I've tried the following:

linux:~ # ldd `which digikam` |grep gphoto
        libgphoto2.so.2 => /usr/lib/libgphoto2.so.2 (0x4173e000)
        libgphoto2_port.so.0 => /usr/lib/libgphoto2_port.so.0 (0x417b8000)
linux:~ # ldd /usr/local/bin/gphoto2 | grep gphoto

linux:~ # ldd /usr/bin/gphoto2 | grep gphoto
        libgphoto2.so.2 => /usr/lib/libgphoto2.so.2 (0x40110000)
        libgphoto2_port.so.0 => /usr/lib/libgphoto2_port.so.0 (0x401ae000)

linux:~ # rpm -qa |grep gphoto
libgphoto2-2.1.99.head.0-12
gphoto-2.1.99head-3

cat ~/.kde/share/apps/digikam/cameras.xml
<!DOCTYPE XMLCameraList>
<cameralist client="digikam" version="1.0" >
 <item port="usb:" title="Kodak Z7590" model="Kodak Z7590" path="/" />
 <item port="usb:" title="USB PTP Class Camera" model="USB PTP Class Camera" path="/" />
</cameralist>

I also have a 2Mb digicam log file if needed.
Comment 1 Ted Hansen 2006-06-13 17:56:56 UTC
I am also getting this error on my newly installed Debian system using kernel 2.6.14, digikam 0.8.1 and 0.8.2 and also on my attempted new install Kanotix system with kernel 2.6.15. Camera is Kodak V550 and the error occurs with both the usb PTP camera  driver and the Kodak V550. Bug may be related to new driver installs because my existing installation Kanotix/Debian kernel 2.6.13 still works prefectly (USB PTP driver) after upgrading to Digikam version 0.8.1.
Comment 2 Ted Hansen 2006-06-23 04:36:51 UTC
appears to be fixed with digikam 0.8.2; gphoto2 & libgphoto version 2-2. 
change to resolved if the original submitter agrees.

 
Comment 3 Michael R. Lindsay 2006-06-23 13:17:16 UTC
I have downloaded Digikam-0.8.2 but so far unable to get ./configure to run without erroring out. The file "config.log" shows the following:
configure:35297: checking for imlib2-config
configure:35328: result: no
configure:35357: WARNING: Imlib 2.x not found.
configure:35369: checking for gphoto2-config
configure:35387: found /usr/bin/gphoto2-config
configure:35399: result: /usr/bin/gphoto2-config
configure:35408: checking for gphoto2-port-config
configure:35426: found /usr/bin/gphoto2-port-config
configure:35438: result: /usr/bin/gphoto2-port-config
configure:35527: checking for libkipi >= 0.1
configure:35574: result: not found

imlib2 version 1.1.1-9 shown installed on system
libkipi version 0.1.1-5 shown installed on system

SUSE Linux 10.0 with kde 3.4.2b

I know I'm overlooking something probably simple such as a non-standard file location. Will keep looking & trying...
Comment 4 caulier.gilles 2006-06-23 13:19:59 UTC
You need to install imlib2 lib and devel package to compile digiKam, not imlib1...

Gilles Caulier
Comment 5 Michael R. Lindsay 2006-06-23 19:11:04 UTC
I downloaded Digikam 0.8.1 in RPM format from Novell and it has solved my problem. Will have to work with version 0.8.2 a lot more to see what I'm doing wrong that is keeping it from installing. As far as I can tell Digikam 0.8.1 did not alter the imlib2 or libkipi files that were already on my system. I am using Novell's OpenSUSE version 10.0 of Linux aand I'm starting to think they may have placed some files in non-standard locations/directories.

 At least now I'm working!! Thanks for your assistance.