Bug 123420 - trying to max. a win. resizable in 1 dimension only should max. the win. in that dimension
Summary: trying to max. a win. resizable in 1 dimension only should max. the win. in t...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-11 09:59 UTC by Stefan Monov
Modified: 2012-03-11 12:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Monov 2006-03-11 09:59:23 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

How to reproduce an example: Try to maximize the Run Command dialog.
Observed behavior: nothing.
Expected behavior: it maximizes horizontally (since it's only resizable horizontally).

Summary: When the user tries to maximize a window which is resizable in one of the dimensions only, the window should get maximized in that dimension.
Comment 1 Stefan Monov 2006-03-11 10:04:20 UTC
Sorry, I made a mistake. I didn't mean to write "Run Command" dialog, but instead the "Page loading" one, which appears when you enter an URL in "Run Command" and which disappears when the page is loaded.
Comment 2 Lubos Lunak 2006-03-16 13:57:12 UTC
In KWin, "full maximize" == "has geometry exactly as the workarea".
Comment 3 Stefan Monov 2006-03-16 16:30:22 UTC
I know, but since the action requested by the user is impossible, the closest one should be executed. But I could be wrong.
Comment 4 Lubos Lunak 2006-04-27 19:17:28 UTC
I may reconsider.
Comment 5 Martin Flöser 2012-03-11 10:20:03 UTC
I think this would be very confusing. The user performs an action and it is only partly executed. This is rather bad. Such actions should be atomic: either fully supported or none at all. Given this I do not consider that this will be implemented.

Furthermore the window decoration buttons explicitly support maximizing either only horizontally or vertically.

Nevertheless I want to thank you for your feature suggestion and I am sorry that this report has been undecided for such a long time.
Comment 6 Thomas Lübking 2012-03-11 12:35:57 UTC
I think you misunderstood him.
As it has been, a window restricted to a maximum vertical or horizontal size could not be maximized at all, there was no maximize button and any attempt to changeMaximize was ignored.

As it is now, the window is maxed out to what is allowed, ie. if it's only restricted in one direction, that direction will be resized to the maximum and the other direction is maximized in the classical sense.

In other words, this actually works =)
(and is luckily a far corner case, because for a window with one static dimension, it might really be confusing, since that limitation isn't reflected otherwise)