Bug 122807 - loading attached file crashes kword
Summary: loading attached file crashes kword
Status: RESOLVED DUPLICATE of bug 41954
Alias: None
Product: kword
Classification: Miscellaneous
Component: general (show other bugs)
Version: 1.5 or before
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-27 20:48 UTC by Jiri Palecek
Modified: 2006-04-27 11:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
This is the bzipped document that fails to read (151.60 KB, application/bzip2)
2006-02-27 20:50 UTC, Jiri Palecek
Details
Kword writes lots of debugging output (3.56 KB, application/bzip2)
2006-02-27 20:52 UTC, Jiri Palecek
Details
Backtrace (3.67 KB, text/plain)
2006-02-27 20:58 UTC, Jiri Palecek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Palecek 2006-02-27 20:48:31 UTC
Version:           1.4.2 (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages

Hello,

when I load the attached file (it's a MS Word document with nested tables),
kword crashes at the end of the loading process (that is, progress bar at 100%).

  Jiri Palecek
Comment 1 Jiri Palecek 2006-02-27 20:50:52 UTC
Created attachment 14898 [details]
This is the bzipped document that fails to read
Comment 2 Jiri Palecek 2006-02-27 20:52:46 UTC
Created attachment 14899 [details]
Kword writes lots of debugging output
Comment 3 Jiri Palecek 2006-02-27 20:58:08 UTC
Created attachment 14900 [details]
Backtrace
Comment 4 David Faure 2006-02-27 23:44:18 UTC
Crash in the table code.

#5  0xb6264e3f in KWTableFrameSet::TableIterator<2>::toFirstCell ()
   from /usr/lib/kde3/libkwordpart.so

I fixed the crash for 1.5 (revision 514299 and a few similar fixes before),
but the table doesn't appear well at all; it's probably a multi-page table,
which kword doesn't support at this point.
Comment 5 Thomas Zander 2006-03-14 00:25:05 UTC

*** This bug has been marked as a duplicate of 41954 ***