Bug 122731 - KMail crash in KPIM::ProgressItem::setComplete
Summary: KMail crash in KPIM::ProgressItem::setComplete
Status: RESOLVED DUPLICATE of bug 121384
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-26 11:01 UTC by Robert Gomułka
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (5.35 KB, text/plain)
2006-02-26 11:01 UTC, Robert Gomułka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gomułka 2006-02-26 11:01:32 UTC
Version:           1.9.1 (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I left my computer working. KMail had automatic mail checking turned on. When I looked at it (after few hours) I saw that KMail crashed. Unfortunately cannot provide a path to reproduce. Backtrace wil be attached.
Comment 1 Robert Gomułka 2006-02-26 11:01:52 UTC
Created attachment 14879 [details]
Backtrace
Comment 2 Tommi Tervo 2006-02-27 10:14:48 UTC
#5  0xb68b24bd in KPIM::ProgressItem::setComplete ()
   from /usr/lib/libkdepim.so.1
#6  0xb7dbabdb in KMail::PopAccount::slotJobFinished ()
   from /usr/lib/libkmailprivate.so
#7  0xb7dbb370 in KMail::PopAccount::slotCancel ()
   from /usr/lib/libkmailprivate.so
#8  0xb7dbc572 in KMail::PopAccount::slotResult ()
   from /usr/lib/libkmailprivate.so
#9  0xb7dbc739 in KMail::PopAccount::qt_invoke ()
Comment 3 Thiago Macieira 2006-02-28 19:45:26 UTC
Pasting the whole backtrace:

#5  0xb68b24bd in KPIM::ProgressItem::setComplete ()
   from /usr/lib/libkdepim.so.1
#6  0xb7dbabdb in KMail::PopAccount::slotJobFinished ()
   from /usr/lib/libkmailprivate.so
#7  0xb7dbb370 in KMail::PopAccount::slotCancel ()
   from /usr/lib/libkmailprivate.so
#8  0xb7dbc572 in KMail::PopAccount::slotResult ()
   from /usr/lib/libkmailprivate.so
#9  0xb7dbc739 in KMail::PopAccount::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#10 0xb71377ff in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb5b6c212 in KIO::Job::result () from /usr/lib/libkio.so.4
#12 0xb5bc016c in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#13 0xb5bc02de in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#14 0xb5bc0a1d in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#15 0xb5b874f3 in KIO::SimpleJob::slotError () from /usr/lib/libkio.so.4
#16 0xb5bc1ef3 in KIO::SimpleJob::qt_invoke () from /usr/lib/libkio.so.4
#17 0xb5bc2013 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#18 0xb713792c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb5b6b1cf in KIO::SlaveInterface::error () from /usr/lib/libkio.so.4
#20 0xb5bda580 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#21 0xb5b7f6b7 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#22 0xb5b842ab in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#23 0xb5b8445b in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#24 0xb71377ff in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#25 0xb7138106 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#26 0xb74c61f7 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#27 0xb7157aaa in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#28 0xb70ce122 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#29 0xb70ce314 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#30 0xb77d1d4e in KApplication::notify () from /usr/lib/libkdecore.so.4
#31 0xb705f861 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#32 0xb70bfcdd in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#33 0xb7073542 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#34 0xb70e6b01 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#35 0xb70e6a26 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#36 0xb70ccc35 in QApplication::exec () from /usr/lib/libqt-mt.so.3
Comment 4 Robert Gomułka 2006-03-10 21:40:01 UTC
Hello, isn't this the same bug as (reported previously) 121384?
Comment 5 Ismail Onur Filiz 2006-03-11 07:53:31 UTC
Looks like so. Thanks for noticing.

*** This bug has been marked as a duplicate of 121384 ***