Bug 122333 - Korganizer month widget previous/next month not behaving as expected
Summary: Korganizer month widget previous/next month not behaving as expected
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 129621 140854 151632 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-20 11:18 UTC by Jens Svalgaard Kohrt
Modified: 2009-01-15 08:47 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Svalgaard Kohrt 2006-02-20 11:18:43 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Gentoo Packages

The next/previous month buttons do not work as expected in the month widget.

Steps to reproduce
1. Click February 1
2. Click "Next month"
3. Curser moves to March 1, but the widget still shows February (+ a bit of March)

Expected result:
3. Curser moves to March 1, and the widget shows March

A similar thing occurs in the other direction, e.g., March 28, "Previous Month" still gives you March (with Feb 28 selected).
Comment 1 Reinhold Kainhofer 2006-11-02 19:19:15 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 2 Thomas McGuire 2008-10-05 17:08:18 UTC
*** Bug 129621 has been marked as a duplicate of this bug. ***
Comment 3 Thomas McGuire 2008-10-05 17:08:25 UTC
*** Bug 140854 has been marked as a duplicate of this bug. ***
Comment 4 Thomas McGuire 2008-10-05 17:08:31 UTC
*** Bug 151632 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2008-10-05 18:03:25 UTC
SVN commit 868143 by tmcguire:

When the next month button is clicked in the navigator, always switch
the navigator to the next month, even when the days of the next month
are still displayed after the current month.

BUG: 122333
Comment 6 Wolfram R. Sieber 2009-01-15 08:47:33 UTC
In korganizer 3.5.9 (KDE 3.5.10) this bug is still present.