Bug 122246 - Code completion database hangs while parsing sdl
Summary: Code completion database hangs while parsing sdl
Status: RESOLVED DUPLICATE of bug 78978
Alias: None
Product: kdevelop
Classification: Applications
Component: Language Support: CPP (old) (show other bugs)
Version: 3.3.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-18 20:54 UTC by Leeto Geeklund
Modified: 2013-03-31 00:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The traceback as a file. (9.04 KB, text/plain)
2006-02-18 20:59 UTC, Leeto Geeklund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leeto Geeklund 2006-02-18 20:54:38 UTC
Version:           3.3.1 (using KDE KDE 3.5.1)
Installed from:    Ubuntu Packages
Compiler:           GCC 4.0.2-9ubuntu 
OS:                Linux

The application crashes, giving an SIGABRT, while parsing the SDL include forlder.
After restarting KDevelop the new databse appears in te database list but doesn't work, nothing shows up with CTRL+SPACE, but it's no problem deleting it. 
I've tried a different folder, other library, and it works.

The traceback follows:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
...More of these...
[Thread debugging using libthread_db enabled]
[New Thread 906131136 (LWP 14408)]
[New Thread 894651312 (LWP 14410)]
(no debugging symbols found)
...More of these...
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0x37c629a1 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x37c642b9 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x37e41c84 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#10 0x37e3f915 in __gxx_personality_v0 () from /usr/lib/libstdc++.so.6
#11 0x37e3f94a in std::terminate () from /usr/lib/libstdc++.so.6
#12 0x37e3fa7e in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0x37e3fe81 in operator new () from /usr/lib/libstdc++.so.6
#14 0x37e3ff3d in operator new[] () from /usr/lib/libstdc++.so.6
#15 0x374fa72c in QString::setLength () from /usr/lib/libqt-mt.so.3
#16 0x374faad8 in QString::grow () from /usr/lib/libqt-mt.so.3
#17 0x374fe144 in QString::insert () from /usr/lib/libqt-mt.so.3
#18 0x374fe201 in QString::insert () from /usr/lib/libqt-mt.so.3
#19 0x358a4c00 in Lexer::nextToken () from /usr/lib/libkdevcppparser.so.0
#20 0x358aa737 in Lexer::tokenize () from /usr/lib/libkdevcppparser.so.0
#21 0x358aa93b in Lexer::setSource () from /usr/lib/libkdevcppparser.so.0
#22 0x358cf877 in Driver::parseFile () from /usr/lib/libkdevcppparser.so.0
#23 0x35995785 in CreatePCSDialog::slotSelected ()
   from /usr/lib/kde3/libkdevcppsupport.so
#24 0x3593c1f9 in CreatePCSDialogBase::qt_invoke ()
   from /usr/lib/kde3/libkdevcppsupport.so
#25 0x3593c2a3 in CreatePCSDialog::qt_invoke ()
   from /usr/lib/kde3/libkdevcppsupport.so
#26 0x371e126d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#27 0x371e179e in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#28 0x375a3766 in QWizard::selected () from /usr/lib/libqt-mt.so.3
#29 0x373c1641 in QWizard::showPage () from /usr/lib/libqt-mt.so.3
#30 0x373c0294 in QWizard::next () from /usr/lib/libqt-mt.so.3
#31 0x3593970f in CreatePCSDialog::next ()
   from /usr/lib/kde3/libkdevcppsupport.so
#32 0x375a39a6 in QWizard::qt_invoke () from /usr/lib/libqt-mt.so.3
#33 0x37a3a4af in KWizard::qt_invoke () from /usr/lib/libkdeui.so.4
#34 0x3593c219 in CreatePCSDialogBase::qt_invoke ()
   from /usr/lib/kde3/libkdevcppsupport.so
#35 0x3593c2a3 in CreatePCSDialog::qt_invoke ()
   from /usr/lib/kde3/libkdevcppsupport.so
#36 0x371e126d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#37 0x371e1d08 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#38 0x37578da3 in QButton::clicked () from /usr/lib/libqt-mt.so.3
#39 0x3727bb36 in QButton::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#40 0x3721ba11 in QWidget::event () from /usr/lib/libqt-mt.so.3
#41 0x3717765a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#42 0x37177bda in QApplication::notify () from /usr/lib/libqt-mt.so.3
#43 0x37870c7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#44 0x371089d5 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#45 0x37104099 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#46 0x37102584 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#47 0x3711bcc7 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#48 0x37190153 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#49 0x37176195 in QApplication::enter_loop () from /usr/lib/libqt-mt.so.3
#50 0x373931dc in QDialog::exec () from /usr/lib/libqt-mt.so.3
#51 0x35986563 in CCConfigWidget::slotNewPCS ()
   from /usr/lib/kde3/libkdevcppsupport.so
#52 0x3593cce3 in CCConfigWidgetBase::qt_invoke ()
   from /usr/lib/kde3/libkdevcppsupport.so
#53 0x35981ca5 in CCConfigWidget::qt_invoke ()
   from /usr/lib/kde3/libkdevcppsupport.so
#54 0x371e126d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#55 0x371e1d08 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#56 0x37578da3 in QButton::clicked () from /usr/lib/libqt-mt.so.3
#57 0x3727bb36 in QButton::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#58 0x3721ba11 in QWidget::event () from /usr/lib/libqt-mt.so.3
#59 0x3717765a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#60 0x37177bda in QApplication::notify () from /usr/lib/libqt-mt.so.3
#61 0x37870c7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#62 0x371089d5 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#63 0x37104099 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#64 0x37102584 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#65 0x3711bcc7 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#66 0x37190153 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#67 0x37176195 in QApplication::enter_loop () from /usr/lib/libqt-mt.so.3
#68 0x373931dc in QDialog::exec () from /usr/lib/libqt-mt.so.3
#69 0x37ebbd44 in ProjectManager::slotProjectOptions ()
   from /usr/lib/libkdevshell.so.0
#70 0x37ebf3df in ProjectManager::qt_invoke () from /usr/lib/libkdevshell.so.0
#71 0x371e126d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#72 0x371e1d08 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#73 0x37a3fb17 in KAction::activated () from /usr/lib/libkdeui.so.4
#74 0x37a75664 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#75 0x37a90d36 in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#76 0x37a90feb in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#77 0x371e126d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#78 0x3757031e in QSignal::signal () from /usr/lib/libqt-mt.so.3
#79 0x371fe9cc in QSignal::activate () from /usr/lib/libqt-mt.so.3
#80 0x3730525b in QPopupMenu::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#81 0x37a4b77d in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#82 0x3721ba11 in QWidget::event () from /usr/lib/libqt-mt.so.3
#83 0x3717765a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#84 0x37177bda in QApplication::notify () from /usr/lib/libqt-mt.so.3
#85 0x37870c7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#86 0x371089d5 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#87 0x37103de6 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#88 0x37102584 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#89 0x3711bcc7 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#90 0x37190153 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#91 0x37190076 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#92 0x37176169 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#93 0x0804dda5 in ?? ()
#94 0x3fc03740 in ?? ()
#95 0x080cf318 in ?? ()
#96 0x3fc038bc in ?? ()
#97 0x00000001 in ?? ()
#98 0x08051b1e in vtable for QGList ()
#99 0x00000001 in ?? ()
#100 0x08051c10 in vtable for QGList ()
#101 0x08051bc2 in vtable for QGList ()
#102 0x080513f9 in vtable for QGList ()
#103 0x080513e5 in vtable for QGList ()
#104 0x37c4aab7 in ?? () from /lib/tls/i686/cmov/libc.so.6
#105 0x0804b9a4 in ?? ()
#106 0x37d649fc in ?? () from /lib/tls/i686/cmov/libc.so.6
#107 0x37d66240 in __malloc_initialize_hook ()
   from /lib/tls/i686/cmov/libc.so.6
#108 0x080620e0 in ?? ()
#109 0x00000000 in ?? ()
Comment 1 Leeto Geeklund 2006-02-18 20:59:02 UTC
Created attachment 14764 [details]
The traceback as a file.
Comment 2 Jens Dagerbo 2006-05-01 22:33:04 UTC
Probable dupe.

*** This bug has been marked as a duplicate of 78978 ***
Comment 3 Aleix Pol 2013-03-31 00:51:10 UTC
Moving all the bugs from the CPP Parser. It was not well defined the difference between it and C++ Language Support and people kept reporting in both places indistinctively