Bug 122236 - superkaramba crashes hard when reloading a theme after having changed its code
Summary: superkaramba crashes hard when reloading a theme after having changed its code
Status: RESOLVED UNMAINTAINED
Alias: None
Product: superkaramba
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Ryan Nickell
URL:
Keywords: needs_verification
: 134399 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-18 19:18 UTC by Björn Ruberg
Modified: 2010-08-06 00:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Ruberg 2006-02-18 19:18:13 UTC
Version:           0.38 (using KDE KDE 3.5.1)
Installed from:    Gentoo Packages
Compiler:          4.1.0_beta20050211 
OS:                Linux

I develop ViewPortageX. (find it here: http://www.kde-look.org/content/show.php?content=32012 )
Since I updated to KDE-3.5.1, every time when I change something in the code of ViewPortageX and I have it open at the same time, superkaramba crahs very ugly.
It eats up all CPU-power and I can only kill it with "killall -9 superkaramba" .
That is a ugly bug and it crashs my automatic-update function too.

Everything works with kde-3.4.3 and superkaramba-0.36 on another PC.

I'm using a gcc-4.1 prerelease for compiling kdeutils (and superkaramba).
So this may be caused by gcc-4.1. Perhaps somebody on a more stable system can confirm this, by downloading ViewPortageX, starting it, insert something like a new line in the ViewPortageX.py, saving and seeing what happens.
Comment 1 Ryan Nickell 2006-02-18 23:13:20 UTC
This is a known bug in kdirwatch and the lib maintainer is aware of the issue.
The libs in 3.5.0 are working whereas 3.5.1 has changes in the kdirwatch lib that causes an infinite loop resulting in SK crashes.
Comment 2 Ryan Nickell 2006-09-21 05:32:36 UTC
*** Bug 134399 has been marked as a duplicate of this bug. ***
Comment 3 Scott Ortell 2006-10-29 04:11:56 UTC
I got a backtrace using the kill -SIGSEGV command from the handbook.
This ones reproducible and I would also label it as a regression because this did not happen in an earlier version (last year from what I can recall) in which I used to make on-the-fly changes frequently.
Specifically, I was changing the x and y coordinates of the applet in relation to the desktop.
here's the backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1233483584 (LWP 9612)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb76352ed in select () from /lib/tls/i686/cmov/libc.so.6
#8  0xb746860d in KProcess::commClose (this=0x8553768)
    at /build/buildd/kdelibs-3.5.5/./kdecore/kprocess.cpp:1078
#9  0xb74312f9 in KProcess::start (this=0x8553768, runmode=KProcess::Block, 
    comm=KProcess::Stdout)
    at /build/buildd/kdelibs-3.5.5/./kdecore/kprocess.cpp:453
#10 0xb74314bb in KShellProcess::start (this=0x8553768, 
    runmode=KProcess::Block, comm=KProcess::Stdout)
    at /build/buildd/kdelibs-3.5.5/./kdecore/kprocess.cpp:1131
#11 0x0809676a in DiskSensor::DiskSensor ()
#12 0x0807f3ab in karamba::setSensor ()
#13 0x08084b0d in karamba::parseConfig ()
#14 0x080816d3 in karamba::karamba ()
#15 0x0808202c in karamba::reloadConfig ()
#16 0x0808210e in karamba::qt_invoke ()
#17 0xb6dfa957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0xb6dfae8c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb7d98c20 in KDirWatch::dirty (this=0x8578788, t0=@0xbfad27f4)
    at ./kdirwatch.moc:95
#20 0xb7d98d31 in KDirWatch::setDirty (this=0x8578788, _file=@0xbfad27f4)
    at /build/buildd/kdelibs-3.5.5/./kio/kio/kdirwatch.cpp:1735
#21 0xb7d99663 in KDirWatchPrivate::emitEvent (this=0x82b5c20, e=0x82f1170, 
    event=139949424, fileName=@0x80d46b8)
    at /build/buildd/kdelibs-3.5.5/./kio/kio/kdirwatch.cpp:1267
#22 0xb7dee227 in KDirWatchPrivate::slotRescan (this=0x82b5c20)
    at /build/buildd/kdelibs-3.5.5/./kio/kio/kdirwatch.cpp:1364
#23 0xb7deef6f in KDirWatchPrivate::qt_invoke (this=0x82b5c20, _id=2, 
    _o=0xbfad298c) at ./kdirwatch_p.moc:88
#24 0xb6dfa957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#25 0xb6dfb3fc in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#26 0xb718900a in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#27 0xb6e22662 in QTimer::event () from /usr/lib/libqt-mt.so.3
#28 0xb6d91b88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#29 0xb6d939b7 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#30 0xb74e5db2 in KApplication::notify (this=0xbfad2fa0, receiver=0x82b5c8c, 
    event=0xbfad2cb8)
    at /build/buildd/kdelibs-3.5.5/./kdecore/kapplication.cpp:550
#31 0xb6d24389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#32 0xb6d845d3 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#33 0xb6d38ec5 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#34 0xb6dac25e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#35 0xb6dac06e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#36 0xb6d93731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#37 0x080782ce in main ()
 
Comment 4 Scott Ortell 2006-10-29 04:14:07 UTC
btw, heres my specs:
Qt: 3.3.6
KDE: 3.5.5
SuperKaramba: 0.41
Kubuntu: Edgy
Comment 5 Daniel 2006-12-18 22:03:58 UTC
Confirming this bug as FIXED with SuperKaramba from SVN
Last Changed Author: wirr
Last Changed Rev: 612312
Last Changed Date: 2006-12-10 12:52:32 -0800 (Sun, 10 Dec 2006)

on top of KDE 3.5.5 (OpenSuse Release 45) OpenSuse 10.2

Changing a theme / py file while running the theme now gracefully reloads the theme.

Thx wirr.
Comment 6 Scott Ortell 2008-03-12 05:25:39 UTC
This issue has been fixed (at least for me). Anyone else still having this problem?
Comment 7 FiNeX 2008-11-30 18:14:42 UTC
@Björn: are you still experiencing this crash using more recent superkaramba versions?
Comment 8 Björn Ruberg 2010-08-06 00:32:15 UTC
Well, don't know anymore :) This is outdated stuff, closing.