Bug 122164 - Marking as spam (and all other external programs/filters) inacceptably slow on a low end machine (e.g. PII 500)
Summary: Marking as spam (and all other external programs/filters) inacceptably slow o...
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-17 16:27 UTC by Christian D.
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian D. 2006-02-17 16:27:15 UTC
Version:           1.9.1 (using KDE 3.5.1, Kubuntu Package 4:3.5.1-0ubuntu5 dapper)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.15-15-686

On a large folder (> 500 Mails) applying an external filter (bogofilter in my case) is nearly unusable since it takes ages (> 20 minutes) to complete. Although the GUI hangs not completely the latency is so high that you really can't use KMail while the filtering takes place. I recommend to decouple the filtering by creating an external process and make the filtering parallel. This would also implement support for multicore cpus as a side-effect.
Comment 1 Jonathan Marten 2006-10-28 16:24:38 UTC
Reviewed during KDEPIM bugs day.  Duplicate, or closely related anyway, of 41514.
Comment 2 Albert Astals Cid 2006-10-28 16:25:57 UTC

*** This bug has been marked as a duplicate of 41514 ***