Bug 121991 - WRONG MESSAGE: The format of the specified IP address is not valid
Summary: WRONG MESSAGE: The format of the specified IP address is not valid
Status: RESOLVED FIXED
Alias: None
Product: knetworkconf
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Juan Luis Baptiste
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-15 01:13 UTC by Raúl
Modified: 2006-06-11 08:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Supplied info (58.04 KB, image/jpeg)
2006-02-15 01:19 UTC, Raúl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl 2006-02-15 01:13:11 UTC
Version:           3.5.1 (using KDE KDE 3.5.1)
Installed from:    Ubuntu Packages

Problem configuring device eth0 with knetworkconf, when supply following info:

Type: Manual
IP Address: 10.255.30.50
Netmask: 255.255.240.0
Description: Ethernet Network Device
Broadcast: 10.255.31.255
Gateaway: 10.255.16.254
Dialogbox screenshot: http://img103.imageshack.us/my.php?image=knetworkconfbug3qe.jpg

When press ok, recibe message: "The format of the specified netmask is not valid.".

My network parameters are all right, and by configuring network using another interface or manual network config files, all work fine.

PD: How to reproduce:

1. "KDE Menu/System Settings/Network Settings"
2. "Administrator Mode" button, enter password.
3. Select eth0 network interface, press "Configure interface ..." button.
4. Supply info and press OK, and error is displayed.

NOTE: The same problem on 3 KUbuntu machines with KDE 3.5.1. and the same local network, just diferent IP.

Thanks,

Raúl.
Comment 1 Raúl 2006-02-15 01:15:37 UTC
Excuse me, message error is: "The format of the specified IP address is not valid."
Comment 2 Raúl 2006-02-15 01:19:37 UTC
Created attachment 14703 [details]
Supplied info
Comment 3 Łukasz Stefaniak 2006-06-05 21:23:15 UTC
I have the same problem. It's probably caused by 255 in adress, I can't enter ip in form xx.xx.255.xx
Comment 4 Thiago Macieira 2006-06-11 08:37:41 UTC
SVN commit 550121 by thiago:

Fix the address validator. 255 is obviously a valid part of an IP
address.

One should also note that the netmask validator is incomplete. It
should check for a sequence of 1's followed by a sequence of
0's. Anything else is not a valid netmask.

BUG:121991


 M  +1 -1      kaddressvalidator.cpp  


--- branches/KDE/3.5/kdeadmin/knetworkconf/knetworkconf/kaddressvalidator.cpp #550120:550121
@@ -43,7 +43,7 @@
       return false;
     if ((i == 0) && (number == 0))
       return false;
-    if ((number < 0) || (number >= 255))
+    if ((number < 0) || (number > 255))
       return false;
     if ((i == 3) && (number == 0))
       return false;      
Comment 5 Thiago Macieira 2006-06-11 08:40:35 UTC
SVN commit 550122 by thiago:

INTEGRATION:/branches/KDE/3.5/kdeadmin/knetworkconf/knetworkconf 550121
Fix the address validator. 255 is obviously a valid part of an IP
address.

One should also note that the netmask validator is incomplete. It
should check for a sequence of 1's followed by a sequence of
0's. Anything else is not a valid netmask.

CCBUG:121991


 M  +1 -1      kaddressvalidator.cpp  


--- trunk/KDE/kdeadmin/knetworkconf/knetworkconf/kaddressvalidator.cpp #550121:550122
@@ -43,7 +43,7 @@
       return false;
     if ((i == 0) && (number == 0))
       return false;
-    if ((number < 0) || (number >= 255))
+    if ((number < 0) || (number > 255))
       return false;
     if ((i == 3) && (number == 0))
       return false;