Bug 121759 - konqueror crashes on a google cache page
Summary: konqueror crashes on a google cache page
Status: RESOLVED DUPLICATE of bug 106795
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-11 14:06 UTC by christophe_goudey
Modified: 2006-02-11 17:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christophe_goudey 2006-02-11 14:06:21 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Ubuntu Packages
OS:                Linux

konqueror crashes on this google cache page :
http://72.14.207.104/search?q=cache:saRzdB-jusAJ:membres.lycos.fr/odilraoul/xsara.html+citroen+evasion+%22lettre+x%22&hl=fr&gl=fr&ct=clnk&cd=1&ie=UTF-8

Details of the crash :

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1233369408 (LWP 11974)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb627fe01 in DOM::Node::nodeType () from /usr/lib/libkhtml.so.4
#7  0xb620ce8c in EmbedLiveConnect::EmbedLiveConnect ()
   from /usr/lib/libkhtml.so.4
#8  0xb6244452 in EmbedLiveConnect::toString () from /usr/lib/libkhtml.so.4
#9  0xb624476d in EmbedLiveConnect::toString () from /usr/lib/libkhtml.so.4
#10 0xb60fa5c8 in DOM::RegisteredListenerList::~RegisteredListenerList ()
   from /usr/lib/libkhtml.so.4
#11 0xb61126df in DOM::XMLAttributeReader::~XMLAttributeReader ()
   from /usr/lib/libkhtml.so.4
#12 0xb61127e7 in DOM::XMLAttributeReader::~XMLAttributeReader ()
   from /usr/lib/libkhtml.so.4
#13 0xb613bf9d in DOM::checkChild () from /usr/lib/libkhtml.so.4
#14 0xb609ccfa in KHTMLPart::checkEmitLoadEvent () from /usr/lib/libkhtml.so.4
#15 0xb60cd97b in KHTMLPart::checkCompleted () from /usr/lib/libkhtml.so.4
#16 0xb60cdd31 in KHTMLPart::slotLoaderRequestDone ()
   from /usr/lib/libkhtml.so.4
#17 0xb60dc8d2 in KHTMLPart::qt_invoke () from /usr/lib/libkhtml.so.4
#18 0xb6d3fa56 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb61f0f76 in khtml_jpeg_source_mgr::khtml_jpeg_source_mgr ()
   from /usr/lib/libkhtml.so.4
#20 0xb61f63a4 in khtml_jpeg_source_mgr::khtml_jpeg_source_mgr ()
   from /usr/lib/libkhtml.so.4
#21 0xb61f6537 in khtml_jpeg_source_mgr::khtml_jpeg_source_mgr ()
   from /usr/lib/libkhtml.so.4
#22 0xb6d3f929 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0xb7920bfa in KIO::Job::result () from /usr/lib/libkio.so.4
#24 0xb797196a in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#25 0xb7971adb in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#26 0xb79721a0 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#27 0xb7973712 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#28 0xb6d3f929 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#29 0xb6d403c4 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#30 0xb791bf59 in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#31 0xb798a8d4 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#32 0xb7932920 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#33 0xb7937324 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#34 0xb79374b9 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#35 0xb6d3f929 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#36 0xb6d40238 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#37 0xb709fc67 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#38 0xb6d5ffaa in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#39 0xb6cd6f80 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#40 0xb6cd7172 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#41 0xb74440cc in KApplication::notify () from /usr/lib/libkdecore.so.4
#42 0xb6c67db7 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#43 0xb6cc8acb in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#44 0xb6c7ba60 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#45 0xb6ceecfb in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#46 0xb6ceec1e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#47 0xb6cd5c13 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#48 0xb7f396dc in kdemain () from /usr/lib/libkdeinit_konqueror.so
#49 0xb7c66ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#50 0x080483e1 in ?? ()
Comment 1 Tommi Tervo 2006-02-11 15:11:02 UTC
#4  0x420d5772 in DOM::Node::nodeType (this=0xbfb3267c) at dom_node.cpp:202
#5  0x42026eb4 in KJS::getDOMNode (exec=0x86b6640, n=@0xbfb3267c)
    at kjs_dom.cpp:1439
#6  0x420acae7 in KJS::JSLazyEventListener::parseCode (this=0x842d188)
    at kjs_events.cpp:201
#7  0x420ae6a4 in KJS::JSLazyEventListener::handleEvent (this=0x842d188, 
    evt=@0xbfb326f8) at kjs_events.cpp:149
#8  0x41efaf9c in DOM::NodeImpl::handleLocalEvents (this=0x84c38cc, 
    evt=0x8471420, useCapture=false) at dom_nodeimpl.cpp:605
#9  0x41efb2a2 in DOM::NodeImpl::dispatchGenericEvent (this=0x84c38cc, 
    evt=0x8471420) at dom_nodeimpl.cpp:382
#10 0x41efb62c in DOM::NodeImpl::dispatchWindowEvent (this=0x84c38cc, _id=17, 
    canBubbleArg=false, cancelableArg=false) at dom_nodeimpl.cpp:440
#11 0x41f31976 in DOM::HTMLDocumentImpl::close (this=0x84c38a0)
    at html_documentimpl.cpp:276
#12 0x41ea3947 in KHTMLPart::checkEmitLoadEvent (this=0x881fd68)
    at khtml_part.cpp:2329
#13 0x41ea3cf9 in KHTMLPart::checkCompleted (this=0x881fd68)
    at khtml_part.cpp:2251
#14 0x41ea40b7 in KHTMLPart::slotChildCompleted (this=0x881fd68, 
    pendingAction=false) at khtml_part.cpp:5043
#15 0x41ea40e2 in KHTMLPart::slotChildCompleted (this=0x881fd68)
    at khtml_part.cpp:5030
#16 0x41eb5ab6 in KHTMLPart::qt_invoke (this=0x881fd68, _id=56, _o=0xbfb32a78)
    at khtml_part.moc:541
Comment 2 Maksim Orlovich 2006-02-11 16:46:50 UTC
I think there was some discussion of this nasty on the list earlier:
==13650== Invalid read of size 4
==13650==    at 0x6E4A606: khtml::TreeShared<DOM::NodeImpl>::ref() (shared.h:34)
==13650==    by 0x700FC44: DOM::Node::Node(DOM::NodeImpl*) (dom_node.cpp:148)
==13650==    by 0x6FF14C1: KJS::JSLazyEventListener::parseCode() const (kjs_events.cpp:201)
==13650==    by 0x6FF2B0C: KJS::JSLazyEventListener::handleEvent(DOM::Event&) (kjs_events.cpp:149)
==13650==    by 0x6EAAFDC: DOM::NodeImpl::handleLocalEvents(DOM::EventImpl*, bool) (dom_nodeimpl.cpp:605)
==13650==    by 0x6EAB218: DOM::NodeImpl::dispatchGenericEvent(DOM::EventImpl*, int&) (dom_nodeimpl.cpp:382)
==13650==    by 0x6EAB4BE: DOM::NodeImpl::dispatchWindowEvent(int, bool, bool) (dom_nodeimpl.cpp:440)
==13650==    by 0x6ED5AF4: DOM::HTMLDocumentImpl::close() (html_documentimpl.cpp:276)
==13650==    by 0x6E62F2F: KHTMLPart::checkEmitLoadEvent() (khtml_part.cpp:2329)
==13650==    by 0x6E6323D: KHTMLPart::checkCompleted() (khtml_part.cpp:2251)
==13650==    by 0x6E64308: KHTMLPart::slotLoaderRequestDone(khtml::DocLoader*, khtml::CachedObject*) (khtml_part.cpp:2104)
==13650==    by 0x6E719E0: KHTMLPart::qt_invoke(int, QUObject*) (khtml_part.moc:548)
==13650==  Address 0x9D45954 is 4 bytes inside a block of size 84 free'd
==13650==    at 0x401C1EB: operator delete(void*) (in /usr/lib/valgrind/x86-linux/vgpreload_memcheck.so)
==13650==    by 0x6ED9275: DOM::HTMLFrameSetElementImpl::~HTMLFrameSetElementImpl() (html_baseimpl.cpp:456)
==13650==    by 0x6EC6768: khtml::KHTMLParser::parseToken(khtml::Token*) (htmlparser.cpp:308)
==13650==    by 0x6EC7281: khtml::HTMLTokenizer::processToken() (htmltokenizer.cpp:1666)
==13650==    by 0x6ECB913: khtml::HTMLTokenizer::parseTag(khtml::TokenizerString&) (htmltokenizer.cpp:1166)
==13650==    by 0x6ECBE56: khtml::HTMLTokenizer::write(khtml::TokenizerString const&, bool) (htmltokenizer.cpp:1425)
==13650==    by 0x6EA0B82: DOM::DocumentImpl::write(QString const&) (dom_docimpl.cpp:1315)
==13650==    by 0x6EA0BCD: DOM::DocumentImpl::write(DOM::DOMString const&) (dom_docimpl.cpp:1303)
==13650==    by 0x7012269: DOM::HTMLDocument::write(DOM::DOMString const&) (html_document.cpp:213)
==13650==    by 0x6FA7143: KJS::HTMLDocFunction::tryCall(KJS::ExecState*, KJS::Object&, KJS::List const&) (kjs_html.cpp:108)
==13650==    by 0x6F90870: KJS::DOMFunction::call(KJS::ExecState*, KJS::Object&, KJS::List const&) (kjs_binding.cpp:114)
==13650==    by 0x7138F1D: KJS::Object::call(KJS::ExecState*, KJS::Object&, KJS::List const&) (object.cpp:73)
Comment 3 Maksim Orlovich 2006-02-11 17:22:28 UTC

*** This bug has been marked as a duplicate of 106795 ***