Bug 121653 - [TESTCASE] Yahoo's Fantasy Hockey Page Partially Blank http://hockey.fantasysports.yahoo.com/hockey/
Summary: [TESTCASE] Yahoo's Fantasy Hockey Page Partially Blank http://hockey.fantasys...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 123308 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-09 16:30 UTC by Richard Fujimoto
Modified: 2006-03-09 09:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
A large screenshot of the problem (78.17 KB, image/jpeg)
2006-02-09 16:32 UTC, Richard Fujimoto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Fujimoto 2006-02-09 16:30:12 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Ubuntu Packages
Compiler:          gcc version 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)
 
OS:                Linux

When you visit this page:

http://hockey.fantasysports.yahoo.com/hockey/

There is a big blank area where the content should be.  The content is there because I can click links down the right side of the web site, I just can't see it.

Mozilla Firefox renders this properly
Comment 1 Richard Fujimoto 2006-02-09 16:32:47 UTC
Created attachment 14621 [details]
A large screenshot of the problem
Comment 2 Maksim Orlovich 2006-02-09 16:40:02 UTC
Since it's hockey related, may be I'll take a look :-)
Comment 3 Maksim Orlovich 2006-02-17 04:09:30 UTC
My reduction:

<style type="text/css">
#promotable h3 {
  position:relative;
  display:inline;
}
#promotable h3 div {
  position:absolute;
  top:2px;
}
</style>
<table>
 <tr>
  <td>
    TextTextTextTextTextTextTextText<br>TextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextText<br>TextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextText<br>TextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextTextText

    <table id="promotable">
        <tr>
            <td id="promocontent">
            <h3>Fantasy Sports Profile <div></div></h3>
            </td>
        </tr>
    </table>
  </td>
 </tr>
</table>

Comment 4 Germain Garand 2006-03-01 19:06:43 UTC
SVN commit 514862 by ggarand:

Merge interesting pos children relayout fixlet from WebCore.
Takes down Maks's gimme-my-hockey bug, as a side effect.

BUG: 121653



 M  +3 -2      render_block.cpp  


--- branches/KDE/3.5/kdelibs/khtml/rendering/render_block.cpp #514861:514862
@@ -588,6 +588,7 @@
 
     clearFloats();
 
+    int previousHeight = m_height;
     m_height = 0;
     m_overflowHeight = 0;
     m_clearStatus = CNONE;
@@ -648,14 +649,14 @@
     int oldHeight = m_height;
     calcHeight();
     if (oldHeight != m_height) {
-        relayoutChildren = true;
-
         // If the block got expanded in size, then increase our overflowheight to match.
         if (m_overflowHeight > m_height)
             m_overflowHeight -= (borderBottom()+paddingBottom());
         if (m_overflowHeight < m_height)
             m_overflowHeight = m_height;
     }
+    if (previousHeight != m_height)
+        relayoutChildren = true;
 
     if (isTableCell()) {
         // Table cells need to grow to accommodate both overhanging floats and
Comment 5 Germain Garand 2006-03-04 17:51:30 UTC
bah, not solved - just alleviated. Reopening. 
I *hate* layout-flaging bugs. 
Comment 6 Germain Garand 2006-03-07 14:26:27 UTC
SVN commit 516516 by ggarand:

- relayout/repaint fixes (really fix #121653 rather than voodoo merging)
- widget masks fixes: unbork stacking context walking and layer translation, various optimisations, 
  update widget when clearing mask.
  Now www.hdlma.co.uk is OK too. George's seatguru test site has unfortunately changed its layout at a bad time
  but problem was similar to www.bea.com - bad layer translation.
  I'll now close 31121. Oh Yes I will.

BUG: 121653
BUG: 31121



 M  +25 -0     ChangeLog  
 M  +14 -35    khtmlview.cpp  
 M  +6 -6      rendering/render_block.cpp  
 M  +7 -3      rendering/render_canvas.cpp  
 M  +23 -16    rendering/render_layer.cpp  
 M  +2 -2      rendering/render_layer.h  
 M  +39 -12    rendering/render_object.cpp  
 M  +1 -0      rendering/render_object.h  
 M  +19 -12    rendering/render_replaced.cpp  
 M  +2 -0      rendering/render_replaced.h  
Comment 7 Germain Garand 2006-03-09 09:21:25 UTC
*** Bug 123308 has been marked as a duplicate of this bug. ***