Bug 121207 - use threads for background tasks
Summary: use threads for background tasks
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.1
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-02 09:07 UTC by Pieter Bootsma
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter Bootsma 2006-02-02 09:07:32 UTC
Version:           1.9.1 (using KDE KDE 3.5.0)
Installed from:    Debian testing/unstable Packages
OS:                Linux

When KMail is fetching mail, feeding it to it's spamfilter, etc the GUI is not responsive. It is annoying if you want to do a quick round of reading mail if you have to wait 3 seconds each time you flag your mail as spam.

I haven't checked this, but the cause of this is probably because KMail is single-threaded. If these background tasks could be run in a seperate thread it would greatly improve the responsiveness of KMail.
Comment 1 Thiago Macieira 2006-02-04 14:38:39 UTC
This is probably a duplicate.
Comment 2 Bram Schoenmakers 2007-03-08 23:03:02 UTC
Let me introduce you to KDEs most hated bug.

*** This bug has been marked as a duplicate of 41514 ***