Bug 120999 - KDevelop exits while saving a large docbook file leaving the file truncated
Summary: KDevelop exits while saving a large docbook file leaving the file truncated
Status: RESOLVED DUPLICATE of bug 123315
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-29 20:55 UTC by Joachim Eibl
Modified: 2006-04-19 18:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Eibl 2006-01-29 20:55:29 UTC
Version:           3.3 (using KDE 3.5.0 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15.7-default

While saving my index.docbook-file, kdevelop exits. The file which would be 95 kByte is truncated and only 33 kByte are written on the harddisk.
No crashhandler appears, so it doesn't exactly look like a crash but more like an exit. 

The problem isn't excactly reproducable, but this happened twice within a few minutes. The written length of that file was approximately the same. (I was lucky to notice and to have the backup with "~"-extension.)

I continued editing with kwrite and so far this didn't happen again.
Comment 1 Joachim Eibl 2006-01-30 13:13:27 UTC
Yesterday the bug didn't occur in kwrite, but today I encountered quite the same behaviour in kwrite.

I was editing a file via kwrite (started from the console). Then when I was trying to save for the second or third time (after some small change) kwrite exited with:

kio (KDirWatch): WARNING: KDirWatch::removeDir can't handle '/daten/home/joachim/kdiff3-0.9.89/debug/doc'
*** glibc detected *** corrupted double-linked list: 0x083f9770 ***

[3]-  Der Wecker klingelt     kwrite index.html
--------------
Why is removeDir called in the when I try to save a file?
Could there be a problem that on my system /home is a symbolic link pointing to /daten/home?

When I then list the directory, you can again see that the file is truncated in comparison to the backup.
l index.html*
-rw-r--r--  1 joachim users  65591 2006-01-30 13:02 index.html
-rw-r--r--  1 joachim users 126924 2006-01-30 13:01 index.html~

Hope this helps. It doesn't seem to be kdevelop but the kwrite-part.

Joachim
Comment 2 Joachim Eibl 2006-01-30 13:22:40 UTC
One more update: Now I noticed that the following line also appears on successful saves:

kio (KDirWatch): WARNING: KDirWatch::removeDir can't handle '/daten/home/joachim/kdiff3-0.9.89/debug/doc'
Comment 3 Jens Dagerbo 2006-04-18 23:51:53 UTC
If the error also occurs in kwrite, it's undoubtedly a katepart issue. 

Reassigning.
Comment 4 Dominik Haumann 2006-04-19 18:44:13 UTC
It's always the same:

> *** glibc detected *** corrupted double-linked list: 0x083f9770 ***

Can we find any reason for this?

*** This bug has been marked as a duplicate of 123315 ***