Bug 120924 - javascript created div (part of a date picker) overlays textarea mouse input stops working
Summary: javascript created div (part of a date picker) overlays textarea mouse input ...
Status: RESOLVED DUPLICATE of bug 106080
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 3.5
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-28 18:15 UTC by alan
Modified: 2006-01-28 22:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alan 2006-01-28 18:15:54 UTC
Version:           3.5 (using KDE 3.5.0, Debian Package 4:3.5.0-3 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.14-2-k7

I have a "tapestry" application which includes a javascript created datepicker which pops up as a javascript created div with an absolute position and a zindex of 400

{Part of code doing this

	// Create the top-level div element
	this._calDiv = document.createElement("div");
	this._calDiv.className = "calendar";
	this._calDiv.style.position = "absolute";
	this._calDiv.style.display = "none";
	this._calDiv.style.border = "1px solid WindowText";
	this._calDiv.style.textAlign = "center";
	this._calDiv.style.background = "Window";
	this._calDiv.style.zIndex = "400";
...
	// Calendar body
	div = document.createElement("div");
	div.className = "calendarBody";
	this._calDiv.appendChild(div);
	this._table = div;
	
...
	this._table.onclick = function (e) {
		// find event
		if (e == null) e = document.parentWindow.event;

...}

A small part of the popped up calender overlays the edge of a large textarea field (with no specified zindex).  In this area of the popped up calender the mouse input does not work, so it is impossible to get at some dates.

As a final check - Mozilla Firefox works correctly where this overlap occurs.

The actual application is security controlled (its the edit function to my personal blog at http://www.chandlerfamily.org.uk), but if someone needs me to set up a demo page temporarily I can do so.
Comment 1 Maksim Orlovich 2006-01-28 22:12:37 UTC

*** This bug has been marked as a duplicate of 106080 ***