Bug 120714 - wish: Database understanding image 'mutations'
Summary: wish: Database understanding image 'mutations'
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ImageEditor-Versioning (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-24 15:43 UTC by Robert Scott
Modified: 2022-02-02 23:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Scott 2006-01-24 15:43:51 UTC
Version:            (using KDE KDE 3.5.0KDE 3.4.3)
Installed from:    Gentoo PackagesGentoo Packages

Something that would help novice users a lot would be if the digikam database had a concept of an image having several 'mutations'. Let me explain the problem.

If a novice user wants to make an alteration of an image - say, wants to crop the image, wants to remove redeye, or wants to make a smaller version to email to a friend or post on a website, there are a few hiccups in the process.

1. To save the alteration as a different file, the user has to deal with filenames. Which I'm afraid is scary to a lot of people. The user has to end up doing something like putting 's' on the end of the filename to denote that it's the 'small' version. Which is quite an ugly solution.

2. When saving the alteration of the file, there is the danger of accidentally overwriting the original file. Especially when you've got a lot of images to do and you're going through them robotically.

3. Once you've created the new image, it doesn't inherit its parent's tags. So if you've spent ages tagging all your photos, you've got to repeat that.

4. Once this is done, you end up with your albums having repeats of certain photos. Which is ugly, confusing and a waste of (visual) space. ie- If your images are just resizings, they appear in the thumbnail view to be the same image.

I think an answer to this would be to have 'mutations' of an image that are all seen 'as one' by the database. In the same way an online photo gallery keeps several different resolutions of the same image, but of course doesn't treat them as different images. They're the same image, the mutations have just had different things done to them. And the user would never have to worry about filenames or any of that rubbish which in their minds has nothing to do with trying to edit photographs.

I came upon this thought as I was watching my father (a novice digikam user) edit wedding photos he took. He had to produce an album with appropriately cropped images for positioning. But of course the originals had to be kept because the main idea of the album is as a showcase to let people choose which photos they would like as enlargements. And I realised that back in the old days, a 'real' photographer would _never_ actually alter the original negs. They would be kept absolutely sacred. I'll end this paragraph before it all gets too anecdotal.

This feature would also gel nicely with the upcoming raw file support. Seeing as you can't really write back to raw files, you're going to have to create mutations of an image anyway as soon as the user wants to crop/resize/perspective correct an image.

As far as implementation goes, it's probably not easy - I assume it would involve some sort of semi hidden directory system.
Comment 1 Tom Albers 2006-01-28 14:15:43 UTC
Thanks for taking the time to explain this in detail. A similar bug report exists. I will merge them.

*** This bug has been marked as a duplicate of 103350 ***
Comment 2 caulier.gilles 2022-01-08 11:39:50 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=103350