Bug 120595 - Enable grouping of windows by welding the edges together
Summary: Enable grouping of windows by welding the edges together
Status: RESOLVED INTENTIONAL
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 8 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 30643 243384 315944 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-22 13:09 UTC by Richard Hartmann
Modified: 2013-03-01 15:23 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Hartmann 2006-01-22 13:09:32 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Basically, what i have been thinking about for some time is a way to group application windows together.
While browsing kde-looks.org, i saw that other people have been thinking of welding-like features (think xmms), too. Thus i decided to finallz file this wishlist item :)
(http://www.kde-look.org/content/show.php?content=34104 for reference)


This would mean being able to move, close, resize and start them together.


1) Moving: No-brainer, just alt-click one window or click the window decoration bar


2) Closing: Either create a new icon for 'close all' and put that right of the normal 'close' cross (three crosses behind each other would work, for example) or catch the normal close operation and bring a popup along the lines of 'do you want to close all applications or just this one' with the usual 'do not ask me again' checkbox. Clicking the 'close all' button could ask 'There are other applications welded to this one, do you really want to close them all \n[ ] Do not ask me again'


3) Resizing could basically work like http://www.kde-look.org/content/preview.php?preview=2&id=34104&file1=34104-1.png&file2=34104-2.png&file3=&name=Idea%3A+Welding+Window+Edges but with the addition that a double-click on an edge that meet at a welded corner would allow for independent resizing.


4) Starting welded applications together could be a bit of a problem as there is no application name to represent this grouping (well, duh ;). A possible approach is to call something like `kweld layout.kdw`


Problem: The existing decorations would most likely need to be expanded to
1) represent welding
2) have a new close-all button
On the other hand, with KDE 4 right around the corner ;) the specification for window decorations could just be changed accordingly.
Comment 1 Thiago Macieira 2006-01-23 09:51:06 UTC
Isn't this one of the things that Plasma wanted to do with plasmoids?
Comment 2 Lubos Lunak 2006-01-23 13:16:16 UTC
*** Bug 30643 has been marked as a duplicate of this bug. ***
Comment 3 Jon 2006-09-11 20:22:41 UTC
A similar, but slightly different idea, is to create a "split bar" between any two windows that have their edges snapped together, allowing you to resize both at the same time.  I filed this as Bug 133927
Comment 4 Richard Hartmann 2007-12-18 18:28:27 UTC
What does everyone think? Is the functionality fully implemented with KDE4 & Plasma and the new QT models? If yes, feel free to close this. If not, specifying what people miss would be a Good Thing (tm).
Comment 5 Richard Hartmann 2008-01-10 11:24:45 UTC
http://bugs.kde.org/show_bug.cgi?id=59338 is related and would appear to be a subset of my suggestion.
Comment 6 kdeuser1234 2008-11-01 14:18:38 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Maciej Pilichowski 2009-05-05 15:05:01 UTC
Just as reference:
http://techbase.kde.org/Projects/Usability/NWI

this is summary of the discussion about Nested Windows Interface (kde-usability-devel ML).
Comment 8 Martin Flöser 2010-07-02 22:24:50 UTC
*** Bug 243384 has been marked as a duplicate of this bug. ***
Comment 9 Martin Flöser 2012-03-11 10:08:41 UTC
Implementing such a new windowing workflow is very invasive for the code base of the window manager. In fact it gets very close to writing a new window manager. Given that it does not seem to fit what KWin provides and because of that we cannot implement it.

I am also very sceptical about it from a user point of view. Before you implement such a workflow usability studies have to be performed to evaluate whether this is a behavior suited to the users needs.

Overall I think it's the most honest thing to say that we won't implement new windowing concepts inside KWin. This is just out of scope for this project.

Nevertheless I want to thank you for your suggestion and I am sorry that we are not able to implement the request.
Comment 10 Thomas Lübking 2013-03-01 15:23:25 UTC
*** Bug 315944 has been marked as a duplicate of this bug. ***